Project

General

Profile

"openrc and systemd are in conflict" while OpenRC installation

jkjk2000 - 4 months ago -

I am trying to install Parabola OpenRC from the latest "parabola-openrc-2020.01.18-dual.iso". I was following the beginner's guide wiki page for the installation.

I have nonsystemd repo uncommented and above all other repos (as was by default).

When I try to run pacstrap -i /mnt base base-devel elogind command, it gives me:

...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: openrc and systemd are in conflict
==> ERROR: Failed to install packages to new root

I also tried "base-openrc" instead of "base", but didn't help.

Am I doing anything wrong?

The detailed steps are in this pastebin