Project

General

Profile

Parabola LXDE installation is very slow to boot, fails to install because of a bootloader failure, and AMD RX580 free drivers missing from libre kernel (files attached)

l0tus_core - almost 2 years ago -

I am trying to migrate from Arch to Parabola, but I don't want to mess up my current system, so I am installing it on another drive fresh.

Current concerns/issues:

1. The install fails because of a failure to load the bootloader (install.log attached)
2. When I run dmesg, it says that it is missing free drivers for the AMD GPU (RX 580)
3. The Live USB (LXDE) freezes for awhile before finally booting, the CLI one freezes and never boots.

dmesg (82.5 KB) dmesg
install.log (411 KB) install.log

Replies (5)

RE: Parabola LXDE installation is very slow to boot, fails to install because of a bootloader failure, and AMD RX580 free drivers missing from libre kernel (files attached) - bill-auger - almost 2 years ago -

re 1):

the 'efibootmgr' package is installed on the LiveISO, and the calamres installer works perfectly in QEMU - i would try booting with "legacy BIOS" mode

re 2):

presumably, the error you ar referring to is:

[    7.869977] mc: Failed to load firmware "/*(DEBLOBBED)*/"

that is indicating that the non-free driver is not foundm which is to be expected with linux-libre

re 2):

if the LXDE ISO works, use that - or try booting with "legacy BIOS" mode

RE: Parabola LXDE installation is very slow to boot, fails to install because of a bootloader failure, and AMD RX580 free drivers missing from libre kernel (files attached) - l0tus_core - almost 2 years ago -

Hi Bill,

1. Maybe I wasn't clear enough. The CLI one doesn't even boot into the USB. The LXDE ISO is able to boot into the USB, but fails the install (because it fails to install bootloader).

I can try the Legacy BIOS.

2. I thought we saw on H-Node that the RX-580 works (with 3D acceleration). How could I set it up with libre drivers?

Thanks!
Matt

RE: Parabola LXDE installation is very slow to boot, fails to install because of a bootloader failure, and AMD RX580 free drivers missing from libre kernel (files attached) - l0tus_core - almost 2 years ago -

When I run xrandr, it only detects 1 of my 4 monitors. Is this just because it is in a USB environment or is this due to the GPU driver?

RE: Parabola LXDE installation is very slow to boot, fails to install because of a bootloader failure, and AMD RX580 free drivers missing from libre kernel (files attached) - bill-auger - almost 2 years ago -

the live system is intended to be as close as possible to an
installed system - check that you are actually using the
ati/radeon driver, and not vesa

$ lspci -v | grep 'Kernel driver in use:'

complicated display setups often need a custom xorg.conf - you
probably need to do some reading and/or contact the xorg dev
team, for advice on how to configure it for your setup - the
parabola or arch wikis for example,

https://wiki.parabola.nu/ATI#Dual_Head_Setup

and/or the #xorg freenode channel, or any of the other contact
channels shown on the xorg website

https://xorg.freedesktop.org/wiki/

    (1-5/5)