Project

General

Profile

Ethernet card doesn't show up

infinite_recursion - 5 months ago -

I think some modules need to be loaded through modprobe. Please help. My ethernet card worked in hyperbola so the problem isn't in the card.

I use Realtek Semiconductor RTL810xE PCI Express controller

Stack post:
I recently installed both Hyperbola and Arch and became thorough with installation process. Didn't like them. Installed parabola linux.

When I finally boot into my fresh install,

ip link
doesn't return my ethernet card. I want to connect it to internet and update it.

lspci -v
shows realtek card kernel module not loaded. It is r8169 (or some number)

modprobe r8169
gives module not in kernel error. Please help.

Edit 1: lsmod shows

Module Size UsedBy

xhci_pci 20480 0

ehci_pci 20480 0

I loaded RTL818x_pci yet the card didn't show up.

has aer, dpc, pcie_pme, pciehp

I can execute 'modprobe pciehp'. Others show module not found in kernel directory.


Replies (4)

Ethernet card doesn't show up - bill-auger - 5 months ago -

/me is confused why you installed the hyperbola kernel on a
parabola system

RE: Ethernet card doesn't show up - infinite_recursion - 5 months ago -

I have installed parabola kernel. I was just ruling out the case that ethernet card requires proprietary software.

It used to work on hyperbola kernel.

RE: Ethernet card doesn't show up - reg - about 2 months ago -

The same thing happened to me after a fresh install. As someone pointed out on Reddit (https://www.reddit.com/r/Parabola/comments/fad053/noobie_moment_people/fj0iy4h), installing the udev-init-scripts package fixed the issue.

That package was already installed on my other Parabola computers, so I suppose it used to get installed automatically but doesn't anymore.

RE: Ethernet card doesn't show up - bill-auger - about 2 months ago -

yea we have discussed that - a lot changed when the new 'base'
meta-package was intriduced - i think we need to make udev-init-scripts
a mandatory part of 'base'

    (1-4/4)