Project

General

Profile

pacman2pacman

ubjuzvow - 11 months ago -

Hello, I installed parabola and I love it. I'm using pacman2pacman and it is very interesting but it have a little bugs, and I see none seed package. Does somebody use it? I want to fix the bugs but if the project is abandoned I let it go.


Replies (7)

RE: pacman2pacman - ubjuzvow - 11 months ago -

I see git of pacman2pacman is 4 year old.

RE: pacman2pacman - bill-auger - 11 months ago -

none of the parabola tools are abandoned - if you can fix the
problem, please do - the only problem i am aware of, is that it
can not run as root - i have not tried it in a while though

RE: pacman2pacman - ubjuzvow - 11 months ago -

ok, I'll fix it. Maybe it's just my problem, I get all the processes hanging after each download.

RE: pacman2pacman - bill-auger - 11 months ago -

awesome - thanks for looking into it - if you can identify a
well-defined bug (and reproducible by others), we could open a
bug report about it and go from there

if you make a fix, you could attach patches to the bug report, or
to the mailing list, or if you would prefer pull requests on a
web forge, that could be arranged also

RE: pacman2pacman - ubjuzvow - 10 months ago -

No particular configuration, I installed it and almost every launch I have this problem. It seemed to me by searching the net someone else had this problem but I can't find where anymore. Anyway, I've uninstalled and reinstalled it and still have the problem. If it helps it's the i686 architecture package and I have openrc as init. I use parabola as my OS for a server. Yesterday I tried to go deep and it seems to me that when downloading packages with torrent it also hangs "cat /tmp/pacman2pacman-pipe". These days I have little time, as soon as I can I go deep and release the patch.

RE: pacman2pacman - ubjuzvow - 10 months ago -

XferCommand = /usr/bin/pacman2pacman-get %u %o -d

this is my pacman.conf line fir use pacman2pacman, but not think is there the problem

RE: pacman2pacman - bill-auger - about 1 month ago -

"processes hanging after each download" could be related to this bug report - if your problem is similar, use that ticket instead for future comments

https://labs.parabola.nu/issues/2336

    (1-7/7)