Project

General

Profile

Libre video chat applications

Time4Tea - about 2 months ago -

Hey, is jitsi-meet different to jitsi? If so, why is it not available in the Parabola repos? Is there a freedom concern with it?

With the coronavirus-related lockdown we are going through, I am seeing some pressure from members of my family to start using Zoom for multi-person video calls. I see this as a good opportunity to encourage them to try a free-software alternative. I haven't used jitsi before, but my impression is that jitsi-meet is simpler to get up-and-running, whereas jitsi requires users to sign up with another third-party service (e.g. XMPP, etc.). So, I think jitsi-meet would be easier for them to migrate to and for me to explain to them.

Otherwise are there any other libre Zoom alternatives anyone would recommend, which would be easy to set up for someone using Windows (i.e. my Mum - sorry, she's not a free-software convert!)?


Replies (32)

RE: Libre video chat applications - Time4Tea - about 1 month ago -

I tried jitsi-meet in Iceweasel on my Chromebook, with the media.peerconnection.enabled setting set to true, but I still got the same issue as before. The session ends immediately if I click on the 'settings' button in the menu.

RE: Libre video chat applications - grizzlyuser - about 1 month ago -

It should be kept in mind that only 1:1 calls are end-to-end encrypted in Jitsi Meet, and conferences are not [1]. But the work is in progress on that [2]. So for now if it's not desirable to let third party see the conversation unencrypted, then self-hosting of the instance is the way to go.

[1] https://github.com/jitsi/jitsi-meet/issues/409#issuecomment-260652107
[2] https://jitsi.org/blog/e2ee/

RE: Libre video chat applications - Time4Tea - about 1 month ago -

grizzlyuser Ok, thanks for the info on that. I would consider self-hosting, but I'm not willing to put the time in to set it up if I can't even get meet.jit.si working for myself in a browser first.

I posted an issue report on the Jitsi Meet page and they directed me to http://test.webrtc.org. I ran the tests there and they fail with icecat/weasel on both of my machines. In icecat on my x86 desktop, it can't find the microphone and it's failing network and connectivity. I'm using ALSA direct, not Pulseaudio, so perhaps that may be causing an issue with the mic? Although, audio output works in icecat and I know the camera/mic works with other programs.

RE: Libre video chat applications - bill-auger - 27 days ago -

the last i knew, jitsi-meet is working with the current iceweasel - are people still having trouble with it ?

i suppose it could make a difference depending on if you are using pulse, ALSA, or JACK

RE: Libre video chat applications - Time4Tea - 26 days ago -

bill-auger I was trying it in icecat on x86, but I will install iceweasel and see if it is any better. On that system I am using OpenRC and direct to ALSA, no Pulse.

In the support ticket I had raised with Jitsi Meet, they recommended trying http://test.webrtc.org, to see if the browser-integrated webrtc is working correctly. I tried it with icecat and it didn't seem to be detecting the mic for my webcam. So, that might suggest a compatibility issue with ALSA (although audio output works fine with it in icecat).

RE: Libre video chat applications - bill-auger - 25 days ago -

webrtc is probably disabled in icecat v60 - when icecat v68 is
released, we will try to get that working too

RE: Libre video chat applications - laust - 14 days ago -

Time4Tea wrote:

1. The packages on the Arch repos are out of date.
2. A possible issue with it not working with OpenRC.

The latter would probably be a deal-breaker for me, as I don't like systemd. I might have to investigate a different libre chat option instead.

freemor you said it worked for you. Are you using systemd?

Hi,

I experience erratic behaviour as well with systemd as with openrc, so I doubt that would be the only cause. By erratic, I mean that some messages don't go through like you describe. But sometimes, a bunch of pending messages finds its way and is delivered at the same time.

(26-32/32)