Project

General

Profile

Problem with lxde autostart

Frusinabu - 15 days ago -

Hello.
Installed Parabola linux, everything is fine, it boots into the console.
I want the graphical environment and user autologin to start automatically after loading.


Replies (14)

RE: Problem with lxde autostart - nona - 15 days ago -

As a hint to those who may help you, do you think that you can provide more information? For example,
- do you already have LXDE installed?
- can you launch LXDE? how?
- do you have a greeter?

RE: Problem with lxde autostart - Frusinabu - 15 days ago -

yes, LXDE is installed.

I can't add execution code from the console to the post, the error pops up: "Sorry, that post has too many non-dictionary words. Consider putting long command-line outputs and URLs into a file and attaching it with the 'Browse' button below."

RE: Problem with lxde autostart - nona - 15 days ago -

Frusinabu wrote:

yes, LXDE is installed.

- can you you launch LXDE? how?

I can't add execution code from the console to the post, the error pops up: "Sorry, that post has too many non-dictionary words. Consider putting long command-line outputs and URLs into a file and attaching it with the 'Browse' button below."

- https://labs.parabola.nu/projects/parabola-community-forum/search?scope=&messages=1&q=too%20many%20non-dictionary%20words
- https://labs.parabola.nu/boards/10/topics/1191?r=1193#message-1193
- https://labs.parabola.nu/boards/5/topics/197?r=207

RE: Problem with lxde autostart - Frusinabu - 15 days ago -

Installed packages based on openrc.

pacstrap -i /mnt base base-devel libelogind udev-init-scripts
pacstrap -i /mnt linux-libre-lts networkmanager-openrc openssh-openrc git net-tools grub lvm2 nano cryptsetup syslog-ng-openrc inetutils man-db
pacstrap -i /mnt lxde lxdm-openrc elogind xorg-server xorg-xinit dbus-openrc

Configured lxdm.conf to autologin the user "user".

Autostart decided to do through the "Daemon method":
Added the following line to /etc/rc.conf:


DAEMONS=(lxdm)

but after loading linux I get only console.
Please tell me what did you do wrong?
Thank you.

/etc/lxdm/lxdm.conf

[base]
## uncomment and set autologin username to enable autologin

autologin=user

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
timeout=5

## default session or desktop used when no systemwide config
session=/usr/bin/startlxde

## unconment and set to set numlock on your keyboard
numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/1ib/1xdn/1xdn-greeter-gtk

[server]

## arg used to start xserver, not fully function
arg=/usr/bin/X -background vt1

# uncomment this if you really want xserver listen to tcp
# tcp_listen=1

# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=Adwaita

rc-update

      agetty.tty1 |             default                                
      agetty.tty2 |             default                                
      agetty.tty3 |             default                                
      agetty.ttyd |             default                                
      agetty.tty5 |             default                                
      agetty.tty6 |             default                                
           binfmt |       boot                                         
         bootmisc |       boot                                         
          cgroups |                                           sysinit  
             dbus |             default                       sysinit  
            devfs |                                                    
            dmesg |                                           sysinit  
             fsck |       boot                                         
  hostnamekeymaps |       boot  boot                                   
        killprocs |                                 shutdown           
kmod-static-nodes |                                                    
          sysinit |                                                    
            local |             default  nonetwork                     
       localmount |       boot                                         
  Toopbacknodules |       boot                                         
             boot |                                                    
         mount-ro |                                 shutdown           
             mtab |       boot                                         
         netmount |             default                                
       procfsroot |       boot                                         
     save-keymaps |       boot                                         
             boot |                                                    
save-termencoding |       boot                                         
        savecache | sshd                                      shutdown 
          default |                                                    
             swap |       boot                                         
           sysctl |       boot                                         
            sysfs |                                           sysinit  
        syslog-ng |             default                                
     termencoding |       boot                                         
             udev |                                           sysinit  
     udev-trigger |                                           sysinit  
          urandom |       boot                                         
              xdm |             default                                                                                              

rc-status

Runlevel: default
  dbus                       [ started 00:16:48 (0) ]
  netmount                                [ started ]
  syslog-ng                               [ started ]
  sshd                                    [ started ]
  local                                   [ started ]
  agetty.tty4                [ started 00:16:48 (0) ]
  agetty.tty5                [ started 00:16:48 (0) ]
  agetty.tty3                [ started 00:16:48 (0) ]
  agetty.tty2                [ started 00:16:48 (0) ]
  agetty.tty6                [ started 00:16:48 (0) ]
  agetty.ttyl                [ started 00:16:48 (0) ]
Dynamic Runlevel: hotplugged  
Dynamic Runlevel: needed/wanted
  NetworkManager                          [ started ]
Dynamic Runlevel: manual

After executing the "lxdm" command, my display manager starts up. Snippet from "ps uaxf":


root      1529  0.0  0.0   3544   208 ?        S    22:57   0:00 supervise-daemon agetty.tty1 --start --pidfile /run/agetty.tty1.pid --respawn-period 60 /sbin/agetty -- tty1 38400 linux
root      1530  0.0  0.1   6020  3796 ?        Ss   22:57   0:00  \_ login -- root
root      1681  0.0  0.2   7820  4380 tty1     Ss   22:57   0:00      \_ -bash
root      1684  0.0  0.1   4816  3496 tty1     S+   22:57   0:00          \_ /usr/sbin/lxdm-binary
root      1686  0.5  3.7 642932 73592 tty1     Sl+  22:57   0:00              \_ /usr/lib/Xorg -background none :0 vt01 -nolisten tcp -novtswitch -auth /var/run/lxdm/lxdm-:0.auth
lxdm      1738  0.6  2.5 392428 49948 tty1     Sl+  22:57   0:00              \_ /usr/lib/lxdm/lxdm-greeter-gtk

1.jpg (54.5 KB) 1.jpg
2.jpg (38.9 KB) 2.jpg
3.jpg (37.2 KB) 3.jpg

RE: Problem with lxde autostart - nona - 15 days ago -

Before going any further, keep in mind that I am just another user, not some sort of wizard.

Once that is solved, the next step would be the auto-login (for which I have no experience).

RE: Problem with lxde autostart - Frusinabu - 14 days ago -

Have you followed this?: https://wiki.parabola.nu/OpenRC#Login_display_manager

Yes, it doesn't help.


# cat /etc/conf.d/xdm
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | sddm | gpe | entrance | lightdm | lxdm ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
# xdm
DISPLAYMANAGER="lxdm" 

I see that the "daemons method" is on https://wiki.parabola.nu/index.php?title=Display_managers&redirect=no#Daemon_method (hopefully, that is updated info, but does not seem to be sufficient).

Yes, added, does not help.


# tail -2 /etc/rc.conf

DAEMONS=(lxdm)

Nothing helps, Xs don't start stupidly

RE: Problem with lxde autostart - nona - 14 days ago -

  • How do you actually start the GUI?
    • have you tried starting your lxdm as an OpenRC service? not just launching lxdm?
  • Have you tried with another greeter, like lightdm?

Nothing helps, Xs don't start stupidly

I don't know what that means other than "I am frustrated with this". Take it easy, it's just a computer (a dumb machine).

If installing again in a virtual machine is an option, you could try the Calamares setup, where there may be a way to select automatic login (if I remember correctly).

RE: Problem with lxde autostart - bill-auger - 14 days ago -

On Mon, 01 Aug 2022 20:44:41 +0000 wrote:

Added the following line to /etc/rc.conf:
DAEMONS=(lxdm)

i dont think you should have done that - i never did - the
process is explained on the openrc guide

the openrc guide mentions the 'displaymanager-openrc' package -
that package no longer exists though - the wiki needs an update
there - for LXDM install 'lxdm-openrc'

RE: Problem with lxde autostart - Frusinabu - 14 days ago -

Thank you very much everyone for your help.
After much torment, I decided to reinstall parabola.
Surprisingly, lxdm started up the first time both through /etc/inittab and through DAEMONS.
What exactly was the cause of the problem, I did not understand. Presumably some package was missing, because. due to there were problems installing packages.

RE: Problem with lxde autostart - nona - 13 days ago -

bill-auger wrote:

... the wiki needs an update
there - for LXDM install 'lxdm-openrc'

I don't see an "Edit" anywhere. I may not have permission to do that. How do I know if I can? What should I do to update it? Thanks.

RE: Problem with lxde autostart - nona - 13 days ago -

Frusinabu wrote:

Thank you very much everyone for your help.
After much torment, I decided to reinstall parabola.
Surprisingly, lxdm started up the first time both through /etc/inittab and through DAEMONS.
What exactly was the cause of the problem, I did not understand. Presumably some package was missing, because. due to there were problems installing packages.

Go figure! Well, it's solved and frustration is gone :) .

RE: Problem with lxde autostart - bill-auger - 13 days ago -

the install guides are protected

the wiki needs more than that one change - megver broke several
important install instructions this month - he promised to
correct them; but has not done it yet - i reminded hm again
yesterday

RE: Problem with lxde autostart - Frusinabu - 12 days ago -

bill-auger wrote:

On Mon, 01 Aug 2022 20:44:41 +0000 wrote:
for LXDM install 'lxdm-openrc'

There is one caveat: the 'lxdm-openrc' package conflicts with the 'lxdm' package.
Installing 'lxdm-openrc' will also install the 'lxdm-gtk3' package and remove 'lxdm'.


# pacman -Si lxdm-openrc
Repository      : nonsystemd
Name            : lxdm-openrc
Version         : 20220104-1
Description     : OpenRC lxdm init script
Architecture    : any
URL             : https://gitea.artixlinux.org/artixlinux/packages-openrc
Licenses        : GPL2
Groups          : openrc-galaxy
Provides        : init-displaymanager
Depends On      : lxdm-gtk3  openrc
Optional Deps   : None
Conflicts With  : init-displaymanager
Replaces        : None
Download Size   : 3.32 KiB
Installed Size  : 0.34 KiB
Packager        : David P. <megver83@parabola.nu>
Build Date      : Mon Jul 18 01:50:39 2022
Validated By    : MD5 Sum  SHA-256 Sum  Signature

RE: Problem with lxde autostart - bill-auger - 12 days ago -

that does look like a problem

if you want to use the GTK2 builds of LXDE/LXDM, install lxdm-openrc like this:

# pacman -S lxdm-openrc --assume-installed=lxdm-gtk3
    (1-14/14)