Project

General

Profile

Please Help With WIFI USB Thinkpenguin

EVILED - about 1 month ago -

Hello.

I am trying to get my thinkpenguin wifi USB to work.

I don't really know what I'm doing or where to start. I have being going off of online videos for setting up arch on wifi and hoping it would work the same for Parabola.

I'm being told to use iwctl. device list keeps not showing anything. at first iwctl wouldn't even load. Kept hanging on waiting for IWD. So, then I did systemctl --now enable iwd. Now iwctl opens, but device list won't show my usb wifi. It returns nothing at all in the list.. usbls does show my device.

What am I doing wrong?

When everything is working, I would like to be able to see my wifi and make connections in the knetworkmanager tray app. But, that doesn't show anything either. Just my Ethernet.

Please help. Thank you.


Replies (5)

Please Help With WIFI USB Thinkpenguin - bill-auger - about 1 month ago -

ive never used any if those tools you mentioned - AFAICT,
parabola has no 'knetworkmanager' program

did you test it with any of the more conventional tools such as
`iwconfig` and `ip link` ?

i would uninstall 'iwd' and try 'networkmanager' instead - and
use the `nmtui` tool at first to configure it - if you get
networkmanager working, i expect that knetworkmanager would use it

RE: Please Help With WIFI USB Thinkpenguin - anonymous - about 1 month ago -

Hello, please give more information about device. Attach file with output of commands:

$ lshw -c network
$ lsusb -v
$ sudo dmesg

Interested part about wifi device. Be careful, the output contain confidential information, mac-adress for example. Clean the unnecessary.
Firstly, check, that the device is identified.
$ ip a
$ iwconfig

Try use $ nmcli (networkmanager) from terminal. Also try
$ iw dev wlan0 link
$ ip link set wlan0 up
$ rfkill unblock wifi
$ rfkill list

Also try configurating and using wpa_supplicant for connection. Try read in Internet about you problem and variants connection (cli/gui). Try to solve by checking work step by step process connection you device with Access Point. Start from:
https://wiki.archlinux.org/title/Network_configuration/Wireless
https://wiki.archlinux.org/title/Network_Debugging
https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Networking

RE: Please Help With WIFI USB Thinkpenguin - EVILED - about 1 month ago -

I have no good idea how to connect to a wireless router without a GUI. So, I don't know most of what these commands do.

$ lsusb
Qualcomm Atheros Communications AR9271 802.11n

$ rmmod ath9k
rmmod: ERROR: Module ath9k is not currently loaded

$ rmmod ath9k_htc
rmmod: ERROR: Module ath9k_htc is not currently loaded

$ iw dev wlan0 link
bash: iw: command not found

$ lshw -c network
bash: lshw: command not found

$ iwconfig
lo        no wireless extensions.

Trisquel finds the USB wifi automatically and let's me see my wifi router in the GUI right click menu to put in my password and connect to it. So, I don't think it's a Free Software driver issue.

I tried nmtui but it didn't list wifi, only Ethernet. I went to add wifi, but instead of just automatically filling it in like it should it wanted me to know network information. I tried to leave it all blank and just hit OK; but it wouldn't let me.

I prefer using Parabola because it's a rolling release and keeps my software up to date. That's why I want to get this working.

RE: Please Help With WIFI USB Thinkpenguin - anonymous - about 1 month ago -

$ sudo pacman -S parabola-base linux-libre-firmware network-manager-applet wireless_tools wireless-regdb
$ sudo systemctl enable NetworkManager
$ sudo reboot

This should help. On the panel you can see the Networkmanager applet in which you can connect to a wireless network. If this did not help, repeat the commands above (now they should work, attach files here), and also try to connect through the terminal (command $ nmcli): https://wiki.archlinux.org/title/NetworkManager. Also read about it here: https://wiki.parabola.nu/Wireless_Setup

Note: you can redirect output of command to file using symbols > (only stdout) and &> (stderr and stdout). For example:

$ sudo dmesg > ~/dmesg.log
$ sudo pacman -Syu &> ~/pacman.log

RE: Please Help With WIFI USB Thinkpenguin - EVILED - about 1 month ago -

Thank you all for helping.

Installing linux-libre-firmware and rebooting made it work. I have wifi now.

    (1-5/5)