Project

General

Profile

DRI3 automatically disabled when startx

PrWalterBulbazor - about 2 months ago -

Hi !
I have a problem with my Parabola setup, I don't know how to enable DRI3. It always disable when startx is launched:

grep -iE dri ~/.local/share/xorg/Xorg.0.log
[   741.332]    X.Org Video Driver: 25.2
[   741.332]    X.Org XInput driver : 24.4
[   741.340] (II) xfree86: Adding drm device (/dev/dri/card0)
[   741.342] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 13 paused 0
[   741.356] (II) LoadModule: "dri" 
[   741.356] (II) Module "dri" already built-in
[   741.362] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[   741.363]    Module class: X.Org Video Driver
[   741.363]    ABI class: X.Org Video Driver, version 25.2
[   741.364] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[   741.366]    Module class: X.Org Video Driver
[   741.366]    ABI class: X.Org Video Driver, version 25.2
[   741.366] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
[   741.376] (**) RADEON(0): Option "DRI" "3" 
[   741.555] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
[   741.555] (==) RADEON(0): DRI3 disabled
[   741.567] (II) Initializing extension DRI3
[   741.568] (II) AIGLX: Screen 0 is not DRI2 capable
[   741.678] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[   741.679] (II) Initializing extension XFree86-DRI
[   741.679] (II) Initializing extension DRI2
[   742.039]    Module class: X.Org XInput Driver
[   742.039]    ABI class: X.Org XInput driver, version 24.4

My GPU is an AMD ATI Radeon HD 6320. This is my /usr/share/X11/xorg.conf.d/20-radeon.conf:

Section "Module" 
        Load "dri" 
        Load "glx" 
        Load "extmod" 
Endsection
Section "Device" 
        Identifier "Radeon" 
        Driver "ati" 
        Option "DRI"    "3" 
        Option "AccelMethod" "Glamor" 
EndSection

Thanks !


Replies (1)

DRI3 automatically disabled when startx - bill-auger - 16 days ago -

are you sure that you need a custom conf file?

the default conf file is /usr/share/X11/xorg.conf.d/10-radeon.conf

$ cat /usr/share/X11/xorg.conf.d/10-radeon.conf
Section "OutputClass"
Identifier "Radeon"
MatchDriver "radeon"
Driver "radeon"
EndSection

note Driver "radeon", not 'ati' - that may be important -
according to h-node, 'radeon' is correct kernel module

https://h-node.org/videocards/view/en/817/Advanced-Micro-Devices--AMD--nee-ATI-Wrestler--Radeon-HD-6320-/1/1/undef/undef/undef/undef/video-card-works/6320

see if 'radeon' is among the output of:

$ lspci -nnk | grep 'Kernel modules: '

    (1-1/1)