Project

General

Profile

Issues with usbguard(?)

bernie - about 2 months ago -

I recently installed, configured, enabled and started usbguard. Everything was fine with the devices attached to my computer at the time.
Today I wanted to use an external drive, so plugged it in. It did not appear in Files or Disks. This was expected.

I then used the software to list devices, and used the ID of my drive to allow the device (see attached file).

At this point, I expected my drive to show up in Files and Disks, but it did not. Is there something I need to do to "trigger" Files / Disks to detect new devices?

After this, I tried unplugging and plugging the drive back in again. It seems when I do this, it gets a different ID, so it becomes blocked again.

I tried sleeping / resuming the computer, but it didn't help.

I tried stopping usbguard.service, but then after a couple of minutes all my USB devices stopped working (keyboard and mouse included). Fortunately, my laptop's keyboard and track pad still worked. Surely stopping the service should not block everything connected??

I expect that there are brute-force methods I could use here (generate a full policy again, or disable usbguard and reboot), but I'd prefer to understand how this is properly supposed to work. Some posts online suggested that a popup should appear when a new, unknown device is plugged in, but I didn't see anything like that (this is a much less important issue to me).

usbguard (666 Bytes) usbguard list, allow and confirm device allowed

Replies (1)

RE: Issues with usbguard(?) - bernie - about 2 months ago -

Relevant dmesg output attached. I thought the "Device is not authorized for usage" came from usbguard, but that message appears even when the usbguard service is stopped.

dmesg (485 Bytes) dmesg dmesg output
    (1-1/1)