Project

General

Profile

Bug #1128

Undefined color: "WINDOW_FOREGROUND"

davidlvillegas - almost 6 years ago - . Updated 4 months ago.

Status:
open
Priority:
bug
Assignee:
-
% Done:

0%


Description

NĂșcleo Linux 4.8.3-gnu-1 x86_64
MATE 1.16.0
emacs 25.1-1

When I execute emacs, doens't run, and terminal return:
Undefined color: "WINDOW_FOREGROUND"
If I execute emacs in other tty(without login in mate), works fine.

I think, this is also related to the bug.
When I'm installing Xampp, I get the screeshoots I attach.
When I finish the installation, if I want to execute lampp panel using 'sudo /opt/lampp/lampp panel', the terminal return:
Unknown Error unknown color name "BACKGROUND"


Files

Pantallazo-2016-10-22 16-20-21.png (6.51 KB) Pantallazo-2016-10-22 16-20-21.png davidlvillegas, 2016-10-23 04:35 PM
Pantallazo-2016-10-22 16-29-26.png (41.8 KB) Pantallazo-2016-10-22 16-29-26.png davidlvillegas, 2016-10-23 04:35 PM
pacman-Qe-with-issue.txt (2.89 KB) pacman-Qe-with-issue.txt Avron, 2022-05-01 10:01 AM
xrdb-query-all-with-issue.txt (7.09 KB) xrdb-query-all-with-issue.txt Avron, 2022-05-01 10:02 AM
pacman-Qe-issue-solved.txt (2.9 KB) pacman-Qe-issue-solved.txt Avron, 2022-05-01 10:05 AM
xrdb-query-all-issue-solved.txt (6.21 KB) xrdb-query-all-issue-solved.txt Avron, 2022-05-01 10:05 AM

History

#1

Updated by Avron 4 months ago

This is old but I ran into this problem just now and I solved it and I think I understood the problem.

I looked at xrdb -query -all and I have a number of things like BACKGROUND, WNDOWS_FOREGROUND, etc. These looks like things that a preprocesor should have replaced with something else. So I installed gcc, logged out, logged in and no more such things, actual colors and emacs works fine in graphical mode.

Could that be solved by adding a dependency? However, I am not sure whether that is just for MATE or for Xorg in general. In the meantime, perhaps some advice could be added somewhere.

#2

Updated by bill-auger 4 months ago

this bug report was not explained well - there is not enough
information in this ticket to even begin trouleshooting -
off-hand, those screenshots look like a theming issue -
maybe try a different desktop theme - some dark themes are
incomplete or out-dated

is emacs the only program this relates to?

what steps would someone need to do, in order to see the
supposed problem?

#3

Updated by Avron 4 months ago

I agree that the report was lacking information but I tried to provide more.

I only have the mate themes installed in the default package (see list of packages installed). I tested with themes "YaruOk" and "YaruGreen" which are in there.

When gcc is not installed, emacs won't start in graphic mode. If I install gcc, unlog and relog, emacs starts in graphics mode without problem. If I uninstall gcc, unlog and relog, emacs won't start in graphic mode, so this is easy to reproduce on my computer.

The output of xrdb -query -all shows very clearly why emacs won't start: some colours are defined to text strings that are neither colour names nor hexadecimal colour descriptions. When gcc is installed, xrdb -query -all shows hexadecimal colour descriptions instead, in every place where there were the text strings. Reverting

Simple guess from reading the manual of xrdb: the strings are normally replaced by CPP by something else, so when gcc is installed, CPP is installed and the strings are replaced, but when gcc is uninstalled, the strings are there again.

Given what xrdb -query -all shows, any application that tries to use general X resources for colours should fail, not only emacs. I know nothing about themes, whether it is possible that some themes need CPP while others not.

I attach
- list of installed packages when the issue occurs
- output of "xrdb query -all" when the issue occurs
list of installed packages after installing gcc on top of this
- output of "xrdb -query -all", when the issue does not occur

An obvious solution would be to have CPP installed when mate is installed, perhaps it does not require the whole gcc package, but I know very little about packaging so I have not much clue.

This looks like a general problem that should affect people using Arch, but if one has gcc installed the problem won't occur and perhaps most people have gcc installed.

Let me know if more information is needed.

#4

Updated by bill-auger 4 months ago

excellent, that gives us something to go on

most or all of the related packages come from arch - i dont think parabola changes anything related to MATE, emacs, or GCC - so that would be the next step, to see if the problem can be reproduced on an arch system

Also available in: Atom PDF