Project

General

Profile

Bug #1508

[iceweasel] WebRTC ALSA audio device module is broken

lukeshu - about 2 years ago - . Updated about 2 years ago.

Status:
info needed
Priority:
bug
Assignee:
% Done:

0%


Description

When using iceweasel with ALSA rather than PulseAudio, navigator.mediaDevices.getUserMedia({..., audio: true}) will fail with a message about unable to allocate audiostream.

This is most likely an issue from upstream Firefox, but I would like to verify that before reporting it to Mozilla. I am unsure whether this can be reported to Arch, as I am unsure if Arch builds firefox with ALSA support. Though, the error message is the same in both iceweasel and Arch's firefox.

I have verified this on both i686 and x86_64.


Files

test-getusermedia.html (338 Bytes) test-getusermedia.html bill-auger, 2017-10-25 10:23 AM

History

#1

Updated by oaken-source about 2 years ago

I am not sure how to reproduce this. sound with alsa works fine on my end.

could you give some more details?

#2

Updated by bill-auger about 2 years ago

i tried today with parabola i686 (iceweasel 56.0.1 32-bit) but i could not reproduce this either

#3

Updated by oaken-source about 2 years ago

  • Assignee set to oaken-source
  • Status changed from open to info needed
#4

Updated by lukeshu about 2 years ago

The error doesn't present itself until the promise is fulfilled/rejected.

navigator.mediaDevices.getUserMedia({audio: true})
  .then(function f(e) { console.log("then", e); })
  .catch(function f(e) { console.log("catch", e); })

The "then" case indicates success, the "catch" case indicates failure.

On iceweasel-1:56.0.2-2-i686, I still get the error, this appears in the console:

catch MediaStreamError { name: "NotReadableError", message: "Failed to allocate audiosource", constraint: "", stack: "" }

This issue does not manifest if PulseAudio is running. I haven't verified with Jack or anything ales, but I assume that if Jack is running, it will similarly not manifest.

Also available in: Atom PDF