Project

General

Profile

Bug #1941

Packaging request #1816: [iceweasel] 61.0.2 still needs built for [armv7h]

[iceweasel] Needs rebuilt for [icu] 62 on [i686] and [armv7h]

bill-auger - almost 2 years ago - . Updated 9 months ago.

Status:
not-a-bug
Priority:
bug
Assignee:
% Done:

30%


Description

$ sudo pacman -Syu
....
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (62.1-1) breaks dependency 'icu<62' required by icecat
:: installing icu (62.1-1) breaks dependency 'icu<62' required by iceweasel

History

#1

Updated by jkjk2000 almost 2 years ago

Having the same issue here.

I have updated iceweasel separately and tried again, but no use. :(

#2

Updated by bill-auger almost 2 years ago

this is an anticipated recurring situation - there are a large number of packages that depend on specific version of the 'icu' package - each of those need to be rebuilt every time the 'icu' package changes version - icecat and iceweasel are but 2 examples that get noticed first

#3

Updated by bill-auger almost 2 years ago

  • Assignee set to oaken-source
#4

Updated by bill-auger almost 2 years ago

  • Subject changed from [icecat][iceweasel][icu]: outdated dependency to [iceweasel][icu]: outdated dependency
#5

Updated by jkjk2000 almost 2 years ago

For now I have upgraded my system with:

sudo pacman -Syu --ignore iceweasel,icu

#6

Updated by ovruni almost 2 years ago

#7

Updated by soni almost 2 years ago

Also texlive-bin has this dependency

#9

Updated by ovruni almost 2 years ago

  • Status changed from open to fixed
#10

Updated by ovruni almost 2 years ago

  • Status changed from fixed to open

Enable libre-testing repo and update iceweasel

#11

Updated by ani almost 2 years ago

many of us users are having this issue now still and we are wondering what to do.

#12

Updated by bill-auger almost 2 years ago

  • Parent task set to #1816
#13

Updated by bill-auger almost 2 years ago

  • Assignee changed from oaken-source to lukeshu
#14

Updated by lukeshu almost 2 years ago

  • % Done changed from 0 to 30
  • Subject changed from [iceweasel][icu]: outdated dependency to [iceweasel] Needs rebuilt for [icu] 62 on [i686] and [armv7h]

This is resolved on x86_64.

Arch Linux 32 only just got ICU 62, so it now needs rebuilt on i686.

I've been putting of doing the ARM build.

#15

Updated by shakthimaan almost 2 years ago

I am hitting this error when I try to install iceweasel on Parabola running on an Asus C201 (armv7). If you can provide the build, I can help test the same. Thanks!

#16

Updated by bill-auger 9 months ago

  • Status changed from open to not-a-bug

closing because this issue went stale - icu is at v64 in all repos, and ice* things are pending v68+ now

Also available in: Atom PDF