Project

General

Profile

Housekeeping #2053

Housekeeping #2047: [STICKY][icu]: and friends (x86_64)

[libre/icedove]: rebuild against new icu (x86_64)

freemor - almost 4 years ago - . Updated 9 months ago.

Status:
in progress
Priority:
bug
Assignee:
% Done:

100%


Description

Needs Rebuild against icu

NOTE: remember to rebuild 'nonprism/icedove', 'icedove-extension-enigmail' , and 'libre/icedove-l10n' if the version has changed - all of these are coupled to each specific version of icedove, to avoid breakage


Related issues

Related to Packages - Bug #3115: [icedove][p11-kit][multiple]: libffi.so.7: cannot open shared object filein progress

Actions

History

#1

Updated by freemor almost 4 years ago

  • % Done changed from 20 to 100
  • Status changed from open to fixed

Built, tested, released

#2

Updated by bill-auger over 2 years ago

  • Tracker changed from Bug to Housekeeping
#3

Updated by bill-auger over 2 years ago

  • Status changed from fixed to open
#4

Updated by bill-auger over 2 years ago

  • Assignee deleted (freemor)
#5

Updated by bill-auger over 2 years ago

  • Status changed from open to fixed
#6

Updated by bill-auger over 2 years ago

  • Assignee set to bill-auger
#7

Updated by bill-auger over 2 years ago

  • Subject changed from libre/icedove to [libre/icedove]: rebuild against new icu (x86_64)
#8

Updated by bill-auger over 2 years ago

  • Description updated (diff)
#9

Updated by bill-auger over 2 years ago

  • Description updated (diff)
#10

Updated by bill-auger over 1 year ago

  • Status changed from fixed to open
#11

Updated by bill-auger over 1 year ago

  • Assignee changed from bill-auger to oaken-source
  • Status changed from open to in progress
#12

Updated by dllud 9 months ago

A new rebuild is needed:

XPCOMGlueLoad error for file /usr/lib/icedove/libxul.so:
libicui18n.so.67: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
#13

Updated by dllud 9 months ago

Installing icu-compat-67 works around it for the time being.

#14

Updated by bill-auger 9 months ago

just to note, that i tried many times with multiple versions (68
78, 91), but could get none to compile - this program is always
troublesome

the abslibre 'wip-icedove' branch shows what ive tried so far
https://git.parabola.nu/abslibre.git/log/?h=wip-icedove

for the amount of effort required, and that it spends more
days behind arch than not, we should consider dropping it -
perhaps someone from the community wants to maintain it, in the
way that grizzlyuser has been maintaining iceweasel?

#15

Updated by bill-auger 9 months ago

icedove has been broken since before the new 'icu' this week (#3115) - i tried several version combinations of LLVM/clang, gcc , rust (1.44.1, 1.52.1, and current), and mozilla (68, 78, 91), all unsuccessfully

FWIW, arch32 is still at v68; because they can not get it to build either

currently, any successful icedove build closes both tickets

#16

Updated by bill-auger 9 months ago

  • Related to Bug #3115: [icedove][p11-kit][multiple]: libffi.so.7: cannot open shared object file added

Also available in: Atom PDF