Project

General

Profile

Bug #2142

cups-filters-1.21.6-1.par1-i686 not building with libremakepkg

GNUtoo - over 3 years ago - . Updated over 3 years ago.

Status:
fixed
Priority:
bug
Assignee:
-
% Done:

0%


Description

$ sudo libremakepkg -n parabola-i686
(parabola-i686 is an i686 chroot)

results in:

checking dirent.h presence... yes
checking for dirent.h... yes
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for library containing jpeg_destroy_decompress... -ljpeg
checking for LIBPNG... no
configure: error: in `/build/cups-filters/src/cups-filters-1.21.6':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables LIBPNG_CFLAGS
and LIBPNG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see <http://pkg-config.freedesktop.org/>.
See `config.log' for more details
==> ERROR: A failure occurred in build().
    Aborting...


Related issues

Copied to Packages - Bug #2143: systemd-240.34-3.parabola1-i686 not building with libremakepkgfixed

Actions

History

#1

Updated by GNUtoo over 3 years ago

  • Copied to Bug #2143: systemd-240.34-3.parabola1-i686 not building with libremakepkg added
#2

Updated by GNUtoo over 3 years ago

  • Status changed from open to fixed

fix pushed in git and in the repositories with:

3aac5afbc [cups-filters] fix build on i686

in abslibre.

Also available in: Atom PDF