Project

General

Profile

Bug #2152

[nm-applet] Not authorized to control networking.

anon7mous - 3 months ago - . Updated 3 months ago.

Status:
info needed
Priority:
bug
Assignee:
-
% Done:

0%


Description

I'm running the OpenRC Edtion of Parabola with lightdm and XFCE4.
I use NetworkManager, network-manager-applet and the nm-connection-edtior. The last two seems to be the problem.
If I want to add a WiFi via nm-connection-editor, it is not possible and will be answered with the following error message:

Insufficient privileges.    

If I want to disconnect my wire I get:

(1) org.freedesktop.NetworkManager.network-control request failed: not autorized    

If I open nm-connection-editor as root, I'm able to add a connection but I could not connect to it.
I'm desperate because I've tried everything and nothing works. I've wondered that restart and poweroff works, so I think polkit-elogind works?

My groups:

gid=985(users) Gruppen=985(users),3(sys),986(video),988(storage),990(optical),994(disk),995(audio),998(wheel)

History

#1

Updated by freemor 3 months ago

first thing to check. Is the user that you har having this issue as a member of the 'network' group?

If not please add then to that group and see if the problem persists after logging the user out and back in to pick up the group change.

#2

Updated by anon7mous 3 months ago

I had already tested that, unfortunately without success.
I have also implemented the instructions from the gentoo-wiki: https://wiki.gentoo.org/wiki/NetworkManager#Fixing_nm-applet_insufficient_privileges

How can I come to grips with the cause?

#3

Updated by anon7mous 3 months ago

Sorry that I'm a fool...
I had changed the group in the workaround from "plugdev" to "network".

polkit.addRule(function(action, subject) {
    if (action.id.indexOf("org.freedesktop.NetworkManager.") == 0 && subject.isInGroup("network")) {
        return polkit.Result.YES;
    }
});

Now I'm able to disconnect BUT NOT to connect to an WiFi.
I get this message every time:

Legitimization for wireless network is required
Passwords or encryption keys are needed to connect to the wireless network.

If I enter the password again, the message appears directly again. Presumably, access to the place where the password is stored is incorrect?

#4

Updated by freemor 3 months ago

in your groups listed above 'network' is not included. you said you tried that But I'm unclear if you had added yourself to the network group or thought the policykit thing you did was doing that.

#5

Updated by freemor 3 months ago

looking at that last error it looks like you may not have installed wpa_supplicant-openrc and set it up with rc-update

#6

Updated by anon7mous 3 months ago

Solved, could be closed.
I'm a bit surprised because the bug only disappears if I use the example configuration of wpa_supplicant, but then wpa_supplicant crashes when booting due to bad values in the file.
It seems like wpa_supplicant has to be removed from the default runlevel.

#7

Updated by bill-auger 3 months ago

we should not want to close any issue if there is a bug to fix that could affect others

was this a bug in the software?

was it due to inadequate or missing instructions?

or was just a fluke that hopefully no one else will ever need to worry about?

#8

Updated by bill-auger 3 months ago

  • Status changed from open to info needed
#9

Updated by anon7mous 3 months ago

I think it could be closed.
I've del wpa_supplicant from default runlevel and now there are no problems.
There is a configfile /etc/wpa_supplicant/wpa_supplicant.conf with no content. If I leave this file empty, I get an error,

Also available in: Atom PDF