Project

General

Profile

Bug #2230

[iceweasel][icecat][iceape][icedove] libvpx-1.8.0 Conflicts with Mozilla-based applications

Added by eliotime3000 20 days ago. Updated 18 days ago.

Status:
in progress
Priority:
broken
Assignee:
% Done:

0%


Description

This new version of libpx makes conflict with Mozilla-based apps (Iceweasel, Icedove, IceCat).

The following message describes the situation:

XPCOMGlueLoad error for file /usr/lib/iceweasel/libxul.so:
libvpx.so.5: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Please solve this issue as soon as possible.

Thanks.


Related issues

Related to Packages - Bug #2238: Icedove doesn't start after upgradeduplicate

Actions

History

#1

Updated by bill-auger 20 days ago

  • Priority changed from bug to broken
  • Assignee set to oaken-source
  • Status changed from unconfirmed to confirmed
  • Subject changed from [libvpx] Conflicts with Mozilla-based applications to [iceweasel][icecat][iceape] Conflicts with Mozilla-based applications
$ iceweasel
XPCOMGlueLoad error for file /usr/lib/iceweasel/libxul.so:
libvpx.so.5: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
$ iceape 
XPCOMGlueLoad error for file /usr/lib/iceape-2.49.4/libxul.so:
libvpx.so.5: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
$ icecat 
XPCOMGlueLoad error for file /usr/lib/icecat/libxul.so:
libvpx.so.5: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
#2

Updated by bill-auger 20 days ago

  • Subject changed from [iceweasel][icecat][iceape] Conflicts with Mozilla-based applications to [iceweasel][icecat][iceape] libvpx-1.8.0 Conflicts with Mozilla-based applications
#3

Updated by bill-auger 20 days ago

the temporary fix is to downgrade ffmpeg and libvpx

$ sudo pacman -S wget
$ wget https://repo.parabola.nu/extra/os/x86_64/ffmpeg-1:4.1.1-1-x86_64.pkg.tar.xz
$ wget https://repo.parabola.nu/extra/os/x86_64/ffmpeg-1:4.1.1-1-x86_64.pkg.tar.xz.sig
$ wget https://repo.parabola.nu/extra/os/x86_64/libvpx-1.7.0-1-x86_64.pkg.tar.xz
$ wget https://repo.parabola.nu/extra/os/x86_64/libvpx-1.7.0-1-x86_64.pkg.tar.xz.sig
$ pacman-key --verify ffmpeg-1:4.1.1-1-x86_64.pkg.tar.xz.sig
$ pacman-key --verify libvpx-1.7.0-1-x86_64.pkg.tar.xz.sig
$ sudo pacman -U ./ffmpeg-1\:4.1.1-1-x86_64.pkg.tar.xz ./libvpx-1.7.0-1-x86_64.pkg.tar.xz
#4

Updated by oaken-source 20 days ago

  • % Done changed from 0 to 10
  • Status changed from confirmed to in progress

try icecat-60.3.0_gnu1-4

iceweasel will be later, it's still building :)

#5

Updated by oaken-source 19 days ago

  • % Done changed from 10 to 20

iceweasel-1:65.0.2-1.parabola2 is out

#6

Updated by bill-auger 19 days ago

  • % Done changed from 20 to 0

they both started for me on x86_64

#7

Updated by bill-auger 18 days ago

  • Related to Bug #2238: Icedove doesn't start after upgrade added
#8

Updated by bill-auger 18 days ago

  • Subject changed from [iceweasel][icecat][iceape] libvpx-1.8.0 Conflicts with Mozilla-based applications to [iceweasel][icecat][iceape][icedove] libvpx-1.8.0 Conflicts with Mozilla-based applications
#9

Updated by bill-auger 18 days ago

there is an icedove-60.5 in [libre-testing]

Also available in: Atom PDF