Project

General

Profile

Bug #2252

[umbrello]: Missing shared object file causes startup to fail instantly

ani - 9 months ago - . Updated 9 months ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

100%


Description

My system: x86_64 Parabola GNU/Linux-libre.

Updated via pacman 2019-03-22 twenty to four.

The error is that I execute umbrello5 so the Umbrello program is launching, the program exits instantly with an error message:

umbrello5: error while loading shared libraries: libKDevPlatformTests.so.53: cannot open shared object file: No such file or directory

Expected behavior is that the program will launch and not exit prematurely.

History

#1

Updated by freemor 9 months ago

looks like [libre/kdevelop] has gotten a little stale.
Hopefully it can still be built without qt-webengine

#2

Updated by freemor 9 months ago

Giving it a try with a freshened PKGBUILD

#3

Updated by freemor 9 months ago

Built ok. But libKDevPlatformTests.so.5 still missing due to

-DBUILD_TESTING=OFF

in our version of the PKGBUILD. commenting that out , rebuilding.

#4

Updated by freemor 9 months ago

  • Assignee set to freemor
  • Status changed from unconfirmed to confirmed
#5

Updated by freemor 9 months ago

  • % Done changed from 0 to 30
  • Status changed from confirmed to in progress

x86_64 -> build, tested, pushed.. Missing lib is now present.

Starting build on other two ARCHs

#6

Updated by freemor 9 months ago

  • % Done changed from 30 to 60
#7

Updated by freemor 9 months ago

  • % Done changed from 60 to 100
  • Status changed from in progress to fixed

Also available in: Atom PDF