Project

General

Profile

Bug #2313

[supertuxkart]: Texture flickering (menu/ingame)

ani - 2 months ago - . Updated 2 months ago.

Status:
unconfirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

System

  • Parabola GNU/Linux-libre x86_64 .
  • supertuxkart 1.0-2 .
  • xfdesktop 4.13.3-2 .
  • xfwm4 4.12.5-1 .
  • mesa 19.0.3-1 .

Occurences

The game has flickering textures. The ground, the houses, the doors, they all flicker. The behaviour is new.

Reproducibility

Start supertuxkart and choose "Story mode".

History

#1

Updated by ani 2 months ago

Attached screenshot.

#2

Updated by freemor 2 months ago

Works fine on my old x200

I strongly suspect this is a compatibility issue with your video card or its drivers

I'd suggest:

try adjusting the settings in the game

More info would be useful:

What video card?
what type of system
Did the issue show up after a recent update
did the drivers for your card update at that time
Did this happen with a recent update to supertuxkart

We do not package supertuxkart. and in this case I suspect even if this was pushed up to Arch they would just push it up to the makers of supertuxkart.
So you may wish to check online documentation on the supertuxkart support sites to see if it is a known problem or if there is a fix

#3

Updated by ani 2 months ago

freemor

You write:

  What video card? Intel HD 620.
  what type of system The same as I wrote.
  Did the issue show up after a recent update Yes.
  did the drivers for your card update at that time Probably.
  Did this happen with a recent update to supertuxkart Probably.

#4

Updated by freemor 2 months ago

Thanks that info will be helful to other trying to reproduce.
Can you also run supertuxkart from a terminal to see if it is throwing any complaints while this is happening
Also check out: supertuxkart --help it has many commandline options for fine tuning the graphics

#5

Updated by ani 2 months ago

freemor

No errors.

#6

Updated by freemor 2 months ago

Did you try with: --log
have you tired asking on #supertuxkart on freenode?
Did you try any of the commandline options?

#7

Updated by ani 2 months ago

freemor

You write:

Did you try with: --log It's an invalid parameter.
have you tired asking on #supertuxkart on freenode? I can't, the channel isn't open for guests.
Did you try any of the commandline options? No.

#8

Updated by freemor 2 months ago

Very strange --log works here fine
Try:

supertuxkart --log=0

see also:

supertuxkart --help | less

see if --log is listed an an option

#9

Updated by freemor 2 months ago

Did the recent update to: supertuxkart-1.0-3 resolve this issue

Also available in: Atom PDF