Project

General

Profile

Freedom issue #2399

[sigil][pageedit]: depend on qt5-webengine

bill-auger - 3 months ago - . Updated 3 months ago.

Status:
confirmed
Priority:
freedom issue
Assignee:
-
% Done:

0%


Description

<elibrokeit> heads up: you will need to adapt to the new stable community/sigil release, which uses qt5-webengine
<elibrokeit> you can just grab the old 0.9.14 PKGBUILD though, and bump the pkgrel.
<elibrokeit> also: feel free to blacklist "pageedit" for depending on webengine too.

History

#1

Updated by bill-auger 3 months ago

eli has made a 'sigil-nowebengine' PKGBUILD

https://pkgbuild.com/~eschwartz/sigil-nowebengine/sigil-0.9.14-2.src.tar.gz.sig

thanks @ eli

#2

Updated by bill-auger 3 months ago

the problem o/c is that it is a fork now - depending on how intrusive the changes which remove webkit support will be in the next version, that would determine how intrusive our patches would need to be in order to merge in, or patch over, new versions into the future; and we would have to decide whether or not it will be maintainable, or to keep a package that will never be upgraded, or remove it anyways

Also available in: Atom PDF