Project

General

Profile

Bug #2410

[EFI] [GRUB] Unable to install GRUB when booting EFI

temporaryuser - 2 months ago - . Updated 2 months ago.

Status:
unconfirmed
Priority:
bug
Category:
-
Assignee:
% Done:

0%


Description

When I install GRUB on my EFI device, it says installing GRUB, then system reboots. It looks like GRUB is not installed as system won't boot.
I'm forced to use Legacy boot.
I will try to install another OS later.

History

#1

Updated by temporaryuser 2 months ago

Attempted to install Windows 10 but booting installation media is failed.
Trying Trisquel 8…

#2

Updated by temporaryuser 2 months ago

Trisquel 8 booted in Legacy mode. I don't know what OS to try then.

#3

Updated by bill-auger 2 months ago

  • Status changed from unconfirmed to info needed

depending on which ISO this issue is referring to, there may already be an open BR about it

#4

Updated by temporaryuser 2 months ago

parabola-openrc-lxde-2019.03.11-dual.iso

#5

Updated by temporaryuser 2 months ago

Windows 8.1 failed (endless reboot loop).
Windows 7 success.

#6

Updated by bill-auger 2 months ago

  • Status changed from info needed to unconfirmed

do you have "secure boot" enabled? - you may want to try disabling it or simply use legacy BIOS mode - legacy BIOS mode is perfectly adequate for most people - there is usually no reason to prefer EFI

#7

Updated by temporaryuser 2 months ago

My device does not support Secure/Restricted Boot.

#8

Updated by temporaryuser 2 months ago

This issue is being replaced as I cannot edit it.

#9

Updated by temporaryuser 2 months ago

#10

Updated by GNUtoo 2 months ago

What computer are you using for that (brand, model, versions etc)?

#11

Updated by GNUtoo 2 months ago

  • Assignee set to GNUtoo
#12

Updated by bill-auger 2 months ago

GNUtoo -

if you need to make any changes to parabolaiso, work from the
'unified' branch

there are multiple open issues against one of the ISOs or
another that are loosely related to EFI, GRUB, and libreboot; but
most of them have not been nailed down to a cause yet

the master branch of parabolaiso has the changes that megver has
been making specific to openrc ISOs - that has a newer version
of the EFI tools - eventually those changes on master need to be
merged with the unified branch; but its still not clear which
EFI implementation will work for all ISOs, whether
systemd/openrc, x86_64/i686, and also with libreboot

#13

Updated by temporaryuser 2 months ago

GNUtoo wrote:

What computer are you using for that (brand, model, versions etc)?

https://labs.parabola.nu/issues/2413#note-2

Also available in: Atom PDF