Project

General

Profile

Bug #2418

[core/libevent] on Parabolas mirrors is out of sync with Arch, Breaks [community/tor]

pisechka - 2 months ago - . Updated 2 months ago.

Status:
not-a-bug
Priority:
broken
Assignee:
% Done:

80%


Description

x86_64

tor:
: Started Anonymizing Overlay Network.
/usr/bin/tor: error while loading shared libraries: libevent-2.1.so.7: cannot open shared object file: No such file or directory
: tor.service: Main process exited, code=exited, status=127/n/a
: tor.service: Failed with result 'exit-code'.

libevent:
Packages (1) libevent-2.1.10-1

Total Download Size: 0.25 MiB
Total Installed Size: 1.19 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
error: failed retrieving file 'libevent-2.1.10-1-x86_64.pkg.tar.xz' from redirector.parabola.nu : The requested URL returned error: 404
error: failed retrieving file 'libevent-2.1.10-1-x86_64.pkg.tar.xz' from redirector.parabola.nu : The requested URL returned error: 404
error: failed retrieving file 'libevent-2.1.10-1-x86_64.pkg.tar.xz' from redirector.parabola.nu : The requested URL returned error: 404
error: failed retrieving file 'libevent-2.1.10-1-x86_64.pkg.tar.xz' from redirector.parabola.nu : The requested URL returned error: 404
error: failed retrieving file 'libevent-2.1.10-1-x86_64.pkg.tar.xz' from redirector.parabola.nu : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

I'm understood that parabola is rolling release distro but last time everyone update was someone destroying.

History

#1

Updated by freemor 2 months ago

This is most likely just a case of the mirrors not having sync'd the new package yet.
Tor and libevent installed fine for me when I -Suy'd this morning.
Please try again and let me know.

#2

Updated by pisechka 2 months ago

freemor wrote:

This is most likely just a case of the mirrors not having sync'd the new package yet.
Tor and libevent installed fine for me when I -Suy'd this morning.
Please try again and let me know.

Now i successfully updated but anyway tor have same error and as i understand need create symlink.
Symlink on libevent-2.1.so.6.0.4?

#3

Updated by freemor 2 months ago

  • Priority changed from bug to broken
  • Assignee set to bill-auger
  • Status changed from unconfirmed to confirmed
  • Subject changed from [community/tor] [core/ibevent] to [core/libevent] on Parabolas mirrors is out of sync with Arch, Breaks [community/tor]

Yep. looks like our mirrors are out of sync. Arch has libevent 2.1.11-1 we have 2.1.10-1

Assigning to bill-auger as he'll probably be around before Lukeshu

As a work around you can grab 2.1.11 from the archlinux.org website at:

https://www.archlinux.org/packages/core/x86_64/libevent/download/

and install it with:

sudo pacman -U libevent-2.1.11-1-x86_64.pkg.tar.xz

And then of course restarting Tor.

#4

Updated by freemor 2 months ago

  • % Done changed from 0 to 80
  • Status changed from confirmed to in progress

Now back in sync with some gentle nudging of the db-import services.

Will leave this open till bill-auger or Lukeshu take a look and make sure
that there isn't something broken that would require such manual intervention
all the time.

#5

Updated by bill-auger 2 months ago

  • Status changed from in progress to not-a-bug

this was just normal expected behavior - the repos sync with arch
once per day: core/extra at 00:00, and community at 04:00

the package 'core/libevent' was published at 2019-08-10 00:46
(30 minutes after the daily sync) - parabola would have gotten
it tomorrow

Also available in: Atom PDF