Project

General

Profile

Packaging request #2513

[libretools] needs rebuild for pacman 5.2

infertux - about 1 month ago - . Updated about 1 month ago.

Status:
fixed
Priority:
broken
Assignee:
% Done:

100%


Description

$ sudo pacman -Syu
[...]
installing pacman (5.2.0-2.parabola1) breaks dependency 'pacman<5.2' required by libretools

History

#1

Updated by ovruni about 1 month ago

  • Status changed from unconfirmed to confirmed
#2

Updated by ovruni about 1 month ago

  • Assignee set to ovruni
#3

Updated by bill-auger about 1 month ago

  • Priority changed from bug to broken
  • Status changed from confirmed to open
  • Tracker changed from Bug to Packaging request

ovruni -

i added some features to libretools recently; but i did not rebuild because i wasnt quite sure how to build and publish it - it looks like one of those intermediate soutcr-ball deals like is often handled but those mksource() functions - i have another patch actually; but its not well tested - ive been waiting to ask lukeshu about the workflow; and to check that none of my patches broken anything

if you know how this is done could you explain the workflow

#4

Updated by ovruni about 1 month ago

  • % Done changed from 0 to 90
  • Status changed from open to in progress
#5

Updated by ovruni about 1 month ago

I have pushed libretools-20181004-6.1 in the libre-testing repo. Please let me know if everything is OK.

#6

Updated by infertux about 1 month ago

Thank you @ovruni. Everything looks good to me and I was able to update pacman and yay. Yay! I'll let you close this ticket once the new package lands in the libre repo.

#7

Updated by ovruni about 1 month ago

  • % Done changed from 90 to 100
  • Status changed from in progress to fixed

Also available in: Atom PDF