Project

General

Profile

Bug #2615

pacman -Syu giving errors

Dal - 22 days ago - . Updated 21 days ago.

Status:
unconfirmed
Priority:
bug
Category:
systemd
Assignee:
-
% Done:

0%


Description

Hi everyone,I recently installed parabola systemd lxde edition with calamares installation process. my issue is that the system cannot upgrade when pacman -Syu is used. I tried by refreshing the keyring and also tried fixing with section 1.3 of the pacman troubleshooting in the parabola wiki, and had to skip the archlinux-keyring and archlinux32-keyring because they were giving errors when trying to install but then got stuck in the next step "sudo pacman-key --init" witht the error : "Trust Database could not be updated". This is my second time reinstalling it, which i don't like if there was a way to chroot and mitigate this issue. thanks in advance


Files

error (591 Bytes) error Dal, 2020-02-01 06:52 PM

History

#1

Updated by bill-auger 22 days ago

the system can almost always be repaired by chrooting in - we
can not help without seeing the actual error messages though

what is the actual error message from pacman -Syu ?

also, there are multiple ISOs with calamares, some from 2018 and
some from 2019 - which ISO did you use ?

#2

Updated by Dal 22 days ago

I have the one from 2018 complete.As I said on my original post, sudo pacman-key --init gives the error "ERROR: Trust database could not be updated." I wish I could post the errors but the forum doesn't let me

#3

Updated by Dal 22 days ago

here are the errors

#4

Updated by bill-auger 22 days ago

you can attach a file to any comment using the "browse" button -
that file can contain any text at all

after you make a few successful posts the new user restrictions
will be lifted automatically

you should not need to re-initialize the keyring - the
interesting error message would be the one from the
pacstrap or the installer - if the the installer fails, it will
create a file on the desktop named install.log

if you have one of the "complete" ISOs, you should be able to
install the system with no trouble at all - just make sure that
you disconnect the internet before starting the installer -
otherwise the ISO from 2019 will be less troublesome

#5

Updated by bill-auger 22 days ago

one of the errors in that file suggest that you have destroyed the keyring before running the command

warning: Public keyring not found; have you run 'pacman-key --init'?

it would be very important to boot the ISO clean before running any commands - and when you post errors, please make it clear which commands you have run, and post the complete output - that file you posted has omitted some essential information

again, if you ensure that the network is not connected first, you should not have any problems until after rebooting into the new system, and upgrading for the first time - i have not tried that ISO in a long time; so im not sure - in fact i just deleted it from the website to make sure that no one else uses it - the install path is much cleaner with the systemd-2019 and openrc-2020 ISOs

you may want to join the #parabola IRC channel for help - it would be fairly difficult to walk you through install on the bug tracker with that ISO

https://webchat.freenode.net/?channel=#parabola

#6

Updated by Dal 21 days ago

Thank you so much for your help, I will try once again if not I’ll try the other ISOs.The 2019 systemd is CLI, right?

#7

Updated by bill-auger 21 days ago

no it is an LXDE live system with the graphical calamares
installer and the complete packages set included - it is
for x86_64 only though

#8

Updated by Dal 21 days ago

Yes, I just checked the downloads and is a lxde install. Also, the 2018 version is not there anymore. Thanks again

#9

Updated by bill-auger 21 days ago

  • Category set to systemd
  • Project changed from Packages to Installation media

Also available in: Atom PDF