Project

General

Profile

Packaging request #2657

Linphone

ThisIsMyAccount - 4 months ago - . Updated 4 months ago.

Status:
open
Priority:
wish
Assignee:
-
% Done:

0%


Description

Requesting Linphone, the SIP softphone. The AUR version has weird build errors and it would be nice to just have a package in Parabola's repos instead.

History

#1

Updated by freemor 4 months ago

  • Priority changed from bug to wish

This probably wont happen any time soon. Linphone was just removed. Which means that other devs probably came to the same conclusion I did.
That being, that the new version "Linphone-desktop" has too many depends that are not in the repos and would have to be packaged prior to packaging linphone-desktop.
and then all of that would have to be maintained and rebuilt.

The old version of linphone does not build from the PKGBUILD because the updtream changed the linphone tarball that gets pulled to contain liblinphone instead of a full version of the old linphone.

Even pulling the origional tarball from the previous versions src package on the parabola servers fails to build because other libraries have moved forward breaking it's ability to build.

I have been looking around for a good replacement with sane depends but an not having much luck. Jitsi is still going but need a little love (ongoing) to get it working on ARM

There is pjproject in the repos which I just updated tho that lacks video and ZRTP.

There id Jami which is supposed to work with sip accounts but my luck with it doing so has been mixed (but I haven spent hours puzzling it out either) Jami works well in its default serverless mode and is E2E encrypted in this mode.

there is also qtox which works fine for voice/video and is E2E encrypted.

#2

Updated by ThisIsMyAccount 4 months ago

That's a shame to hear, and yeah, I agree it has quite a lot of dependencies which also deterred me from trying to build it myself. I have the flatpak right now, which works great except I can't seem to give it access to my music directory so I can add my own ringtone. I tried "sudo flatpak override com.belledonnecommunications.linphone --filesystem=/home/user/Music" and if I completely close out linphone and reopen, it still doesn't list that directory when browsing for a new ringtone.

#3

Updated by freemor 4 months ago

Might be easier to just copy the sound file you need into the linphone flatpacks chroot so it can find it.

Also available in: Atom PDF