Project

General

Profile

Bug #2686

Atril can't open pdfs on arm

Time4Tea - 3 months ago - . Updated 3 months ago.

Status:
unconfirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

As far as I can see, the Atril document viewer is not able to open pdf files on arm (I am using a Chromebook C201). The application opens and I get an error: 'File type PDF is not supported'. I have tried with several different pdf files, in both LXDE and Mate.

History

#1

Updated by Time4Tea 3 months ago

Seems to work fine on x86

#2

Updated by bill-auger 3 months ago

it looks like all of the 'atril' dependencies come from
archlkinuxarm, except for 'libsynctex'

libre/libsynctex 2019.51075-7.par2 [instalita]
Library for synchronization between TeX files and resulting file

that description does not indicate that it is related to PDFs -
can you try evince or some other viewer ?

#3

Updated by Time4Tea 3 months ago

bill-auger it turns out it was an issue with poppler. I tried evince and got the same error, but it gave more info and said it was unable to find libpoppler.so.98. My version of poppler seems to be being 'held' at 0.86.1 (which provides libpoppler.so.97), because cups-filters requires that version. So, I created a symlink for libpoppler.so.98 and now pdfs are working in both Evince and Atril.

Also available in: Atom PDF