Project

General

Profile

Bug #2769

Freedom issue #972: TeXLive freedom verification

[texlive-core]: missing /usr/bin/mktexlsr

jerilso - 5 months ago - . Updated about 2 months ago.

Status:
confirmed
Priority:
bug
Assignee:
% Done:

0%


Description

I installed texlive-core with: sudo pacman -S texlive-core.

To clarify, the script in /usr/share/libalpm/scripts/mktexlsr can't find the binary /usr/bin/mktexlsr. It doesn't exist on my computer.

The command that failed to work is: pdflatex example.tex

Thanks for your help.


Files

PKGBUILD (13.8 KB) PKGBUILD texlive-core 2020.55416 PKGBUILD template nona, 2020-07-22 01:37 AM
PKGBUILD (4.32 KB) PKGBUILD texlive-latexextra 2020.55416 PKGBUILD template nona, 2020-07-22 01:37 AM

History

#1

Updated by bill-auger 5 months ago

  • Status changed from unconfirmed to not-a-bug
  • Description updated (diff)

i tried this myself and i got this error:

$ pdflatex some.tex
! LaTeX Error: File `standalone.cls' not found.

i had to install the 'texlive-latexextra' to make the `pdflatex` command work - the texlive-* pacjages i have installed are:

libre/texlive-bin 2020.54586-1.parabola1
libre/texlive-core 2019.50917-1.par2
libre/texlive-latexextra 2019.50920-1.par1

there is a package group 'texlive-most' which would have installed it - in case you have trouble with some other type of files, try installing the whole set:

$ sudo pacman -S texlive-most
#2

Updated by jerilso 5 months ago

Thanks for replying. Sadly, even installing texlive-most doesn't solve my issue. It doesn't change anything actually.

Maybe it's just a problem on my side, i'll try to see.

#3

Updated by jerilso 5 months ago

Hello bill-auger, have you tried on a freshly installed parabola or was it on a computer that already had a working texlive environment?

I have been suggested that I shouldn't use texlive-bin 2019 with texlive-core 2020. Could it be what is causing the issue?

Is there a way to get both texlive-bin 2019 and texlive-core 2019 or texlive-bin 2020 and texlive-core 2020 in parabola?

#4

Updated by bill-auger 5 months ago

what exactly is the error that you see? - the error about mktexlsr is not a problem - i get that too; and it still works as expected - i even opened the generated PDF file; and it looks perfect

also, have you ever used the 'pdflatex' program successfully on your current system?

you can try downgrading poppler and texlive-bin; it did that at first; and it filed in the same way - after i installed 'texlive-latexextra', it worked - then i re-installed the new poppler and texlive-bin; and it still worked

you can try these steps - firstly i needed to uninstall anything that depends on poppler

$ sudo pacman -Rss poppler
$ sudo pacman -S icu-parabola
$ sudo pacman -U https://archive.archlinux.org/packages/p/poppler/poppler-0.86.1-1-x86_64.pkg.tar.zst
$ sudo pacman -U https://repo.parabola.nu/pool/parabola/texlive-bin-2019.51075-7.par1-x86_64.pkg.tar.xz  --assume-installed=icu=65
#5

Updated by jerilso 5 months ago

Hello,

In my first message, I had linked to the pacman logs that I had. Is it still available?

I have only installed parabola a few weeks ago. I have never used pdflatex on this installation before.

The steps you gave me worked, thanks a lot! I guess I needed both texlive-bin 2019 and texlive-core 2019 at the same time for the installation to succeed. Then the upgrade of only one of them seems to work :).

The steps you mentioned installed the package icu-parabola. I already had icu installed. Now I have both. Do I need both?

Thanks a lot

#6

Updated by bill-auger 5 months ago

the OP mentioned that you were going to post some logs; but there
were none

it would be a good idea to keep 'icu-parabola' installed always
that package is meant to smooth transitions from one icu version
to the next in the future - most likely you will need it again
someday anyway

#7

Updated by nona 3 months ago

mktexlsr is needed to install texlive-science

Context:

When installing texlive-science:

sudo pacman -S texlive-science
...
updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]:     chemarrow.map (in /etc/texmf/web2c/updmap.cfg)
updmap [ERROR]:     stmaryrd.map (in /etc/texmf/web2c/updmap.cfg)
updmap [ERROR]:     yhmath.map (in /etc/texmf/web2c/updmap.cfg)
updmap [ERROR]: Did you run mktexlsr?

    You can disable non-existent map entries using the option
      --syncwithtrees.

error: command failed to execute correctly

Running xelatex on my file

xelatex -file-line-error -no-pdf -interaction nonstopmode -shell-escape -output-directory /tmp/ test.tex
...
! LaTeX Error: File `siunitx.sty' not found.

#8

Updated by nona 2 months ago

Can someone reopen this bug or should I create a new one? Thanks.

#9

Updated by bill-auger 2 months ago

nona -

i just made you a moderator - be at liberty to do whatever
you think is best for any ticket

it is best to re-open a ticket if it contains information
which is still relevant, such as if the very same bug
re-appears, soon after being fixed - that is probably the
case with this one

i kinda ignored this one because it is probably just a small
symptom of the larger issue, that all of the texlive packages
need rebuilding now - i am aware of it and started on some of
them

there is also the yet larger discussion of whether we need to
blacklist and re-package texlive at all #972
(plus related: #969 #2695 #2698 #2699 #2700)

#10

Updated by nona 2 months ago

  • Status changed from not-a-bug to confirmed

Thanks, bill. I figured about the packaging after i tried to create the texlive-core package.

Regarding the licenses: Oh, my! a banana and a gorilla you said, right?

I am marking this one as confirmed. I will do what i can with the packaging myself. I think that it's a good moment to read the packaging documentation. Thanks.

#11

Updated by nona 2 months ago

  • Parent task set to #972
#12

Updated by nona 2 months ago

bill-auger wrote:

all of the texlive packages
need rebuilding now - i am aware of it and started on some of
them

I am attaching what runs for me with the current packages for texlive-core and texlive-latexextra once I update the sources to their free equivalents (#2699, #2698, #972)

#13

Updated by bill-auger about 2 months ago

  • Assignee set to bill-auger
  • Subject changed from texlive-core missing /usr/bin/mktexlsr to [texlive-core]: missing /usr/bin/mktexlsr

texlive-core has been upgraded - i think the problem with mktexlsr is that it was moved from one package to another; but at the time of this BR only texlive-bin had been upgraded

Also available in: Atom PDF