Project

General

Profile

Bug #2779

[marble-common] ARM build failure

dllud - 3 months ago - . Updated 2 months ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

Hi,

I am getting the following error when trying to launch marble-qt:

marble-qt: symbol lookup error: marble-qt: undefined symbol: _ZN6Marble18MarbleInputHandler27setMouseViewRotationEnabledEb

My guess is that it comes from the outdated marble-common in libre.

# pacman -Ss marble
libre/marble-common 18.12.2-1.parabola1 [installed]
    Common libraries and plugins for Marble
extra/marble 20.04.1-1 (kde-applications kdeedu)
    Desktop Globe
extra/marble-qt 20.04.1-1 [installed]
    Desktop Globe (Qt version)

marble-common was introduced into libre by oaken-source as part of issue #2117.


Files

0001-libre-marble-update-marble-common-to-20.04.1.patch (1.68 KB) 0001-libre-marble-update-marble-common-to-20.04.1.patch patch dllud, 2020-05-25 09:59 PM
PKGBUILD (2.14 KB) PKGBUILD dllud, 2020-05-25 10:02 PM

History

#1

Updated by dllud 3 months ago

Confirmed. I grabbed the PKGBUILD from libre and updated it to 20.04.1 as per the PKGBUILD from Arch Installing the resulting marble-common package fixes the symbol lookup error and lets marble-qt run with no issues.
I am attaching my patch in case you want to apply it to abslibre. I am attaching the complete PKGBUILD as well.
If no Parabola maintainer can find the time to keep this package up-to-date, I can volunteer to do so.

#2

Updated by bill-auger 3 months ago

for most packages, we dont really have a dedicated maintainer -
when something needs re-building or upgrading, whoever has the
time will usually just do it

it is always encouraged for anyone to help maintain packages -
that makes it easier for "whoever" to find the time to package
it, when there is a known good PKGBULID, that someone has already
checked it over for problems

any PKGBUILD or patch for an existing parabola package, that is
sent to the dev mailing list, with [PATCH] in the message
subject, will be considered - if you make any significant
changes, feel free to add yourself as a "Contributor:", if you
want to

#3

Updated by dllud 3 months ago

bill-auger Thanks for pointing me to the correct channel to send patches to.
I've just sent the patch to the dev mailing list. Unfortunately I wasn't subscribed before sending, therefore it is awaiting moderator approval. Hope you can accept it. Thanks!

#4

Updated by bill-auger 2 months ago

ok, i will pass it on - you wont see any replies though, if
there are follow-questions, unless you subscribe

https://lists.parabola.nu/mailman/listinfo/dev

#5

Updated by dllud 2 months ago

Thanks. I did subscribe to the list after that. I'll keep an eye on it
I'll close this issue once/if the patch gets merged and the package is rebuilt and put into libre.

#6

Updated by dllud 2 months ago

This issue can now be closed. The new version fixing the issue was now pushed into libre by GNUtoo.

#7

Updated by bill-auger 2 months ago

i dont see how that could be - you sent the new PKGBUILD only 2 days ago; and GNUtoo build it only yesterday, yes? - pacman thinks that package has not been updated since 4 days ago for i686 and 10 days ago for the other two arches

i686     Extra     marble-qt     20.04.1-1.0     2020-05-23     
x86_64     Extra     marble-qt     20.04.1-1     2020-05-16     
armv7h     Extra     marble-qt     20.04.1-1     2020-05-16

#8

Updated by dllud 2 months ago

That's the marble-qt package. That one comes from upstream (Arch), as it needs no modifications.
The one that was updated and pushed into libre is marble-common
Only marble-common had the dependency on qt5-webengine, which was removed as part of #2117

#9

Updated by dllud 2 months ago

I did add [marble-qt] to the title of this bug report because that's the package where the error showed itself. But the underlying problem came from the outdated marble-common.

#10

Updated by bill-auger 2 months ago

ok so the ARM package of marble-common still needs updating

#11

Updated by GNUtoo 2 months ago

I tried to build on ARM several times if my memory is correct and it failed the build. Here's the last attempt:

[  5%] Automatic MOC for target astro
[  5%] Built target sgp4_autogen
Scanning dependencies of target MarbleDeclarativePlugin_Resources
[  5%] Built target MarbleDeclarativePlugin_Resources
[  5%] Built target astro_autogen
Scanning dependencies of target marble-behaim_resources
Scanning dependencies of target marble-maps_resources
[  5%] Built target translation_pt_BR_marble_qt
[  5%] Built target marble-behaim_resources
[  5%] Built target marble-maps_resources
Scanning dependencies of target org.kde.plasma.worldclock-plasmoids-metadata-json
Scanning dependencies of target org.kde.plasma.worldmap-wallpapers-metadata-json
[  5%] Generating org.kde.plasma.worldclock-plasmoids-metadata.json
[  6%] Generating org.kde.plasma.worldmap-wallpapers-metadata.json
make[2]: *** [doc/CMakeFiles/doc-index-cache-bz2.dir/build.make:82: doc/index.cache.bz2] Segmentation fault (core dumped)
make[1]: *** [CMakeFiles/Makefile2:3534: doc/CMakeFiles/doc-index-cache-bz2.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Scanning dependencies of target marble_Resources
[  6%] Built target marble_Resources
make[2]: *** [src/plasma/applets/worldclock/CMakeFiles/org.kde.plasma.worldclock-plasmoids-metadata-json.dir/build.make:81: src/plasma/applets/worldclock/org.kde.plasma.worldclock-plasmoids-metadata.json] Segmentation fault (core dumped)
make[1]: *** [CMakeFiles/Makefile2:8154: src/plasma/applets/worldclock/CMakeFiles/org.kde.plasma.worldclock-plasmoids-metadata-json.dir/all] Error 2
make[2]: *** [src/plasma/wallpapers/CMakeFiles/org.kde.plasma.worldmap-wallpapers-metadata-json.dir/build.make:81: src/plasma/wallpapers/org.kde.plasma.worldmap-wallpapers-metadata.json] Segmentation fault (core dumped)
make[1]: *** [CMakeFiles/Makefile2:8181: src/plasma/wallpapers/CMakeFiles/org.kde.plasma.worldmap-wallpapers-metadata-json.dir/all] Error 2
make: *** [Makefile:183: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

The build was launched on a TBS2910 with mostly upstream u-boot (configuration patches pending) that has an I.MX6Q and 2G of RAM.

I can retry again to see if the error is the same.

#12

Updated by bill-auger 2 months ago

  • Status changed from unconfirmed to confirmed
  • Subject changed from [marble-qt] symbol lookup error - try a marble-common rebuild to [marble-common] ARM build failure

Also available in: Atom PDF