Project

General

Profile

Bug #2804

dbus and dbus openrc clash while updating

infinite_recursion - 2 months ago - . Updated 2 months ago.

Status:
duplicate
Priority:
bug
Assignee:
% Done:

0%


Description

When I execute "sudo pacman -Syu"

I get the following message and my updates do not complete:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing dbus (1.12.18-1) breaks dependency 'dbus-openrc' required by avahi-openrc

I use openrc version of parabola ofc.


Related issues

Related to Packages - Bug #2575: [avahi-openrc] Dependency errors when trying to upgrade with pacmanfixed

Actions

History

#1

Updated by bill-auger 2 months ago

  • Assignee set to Megver83
#2

Updated by bill-auger 2 months ago

this looks like a duplicate of #2575 - what do you think megver ?

#3

Updated by bill-auger 2 months ago

  • Related to Bug #2575: [avahi-openrc] Dependency errors when trying to upgrade with pacman added
#4

Updated by Megver83 2 months ago

yep, it's the same thing

infinite_recursion, you should have posted this in the mailing list first, or at least do some digging, as you can see, you made a duplicated report from a fixed issue

you have to install nonsystemd/dbus

https://wiki.parabola.nu/Nonsystemd

make sure to have [nonsystemd] above [core] in pacman.conf

#5

Updated by Megver83 2 months ago

  • Status changed from unconfirmed to duplicate

Also available in: Atom PDF