Project

General

Profile

Bug #2819

icu-parabola required by icedove

libreuser - 10 days ago - . Updated 3 days ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

0%


Description

# pacman -Syu
error: failed to prepare transaction (could not satisfy dependencies)
:: removing icu-parabola breaks dependency 'icu-parabola' required by icedove
x64
openrc

History

#1

Updated by bill-auger 9 days ago

try this:

# pacman -Syu --ignore=icu-65-compat
#2

Updated by doolio 9 days ago

I have a similar and possibly related issue when trying to perform a system upgrade. Current installed version of icu is 65.1-3.0, Icecat version 60.7.0_gnu1-2.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (67.1-1.0) breaks dependency 'icu<66' required by icecat

#3

Updated by bill-auger 8 days ago

  • Status changed from unconfirmed to confirmed

doolio -

your description of the problem can not be completely accurate - icecat 60.7.0_gnu1-2 does not have any conflicts currently - it depends on icu 67 and is installable - off-hand i can only suggest to run `pacman -Syu` - if you still have trouble, be sure to include the exact command which you typed in addition to the errors that it produced, and which arch you are runnig

#4

Updated by bill-auger 8 days ago

  • Description updated (diff)
#5

Updated by bill-auger 7 days ago

  • Status changed from confirmed to in progress

icedove v1:68.9.0-1.parabola1 fixes this - x86_64 is in the repos - i686 is still building

#6

Updated by bill-auger 7 days ago

  • Assignee set to bill-auger
#7

Updated by bill-auger 7 days ago

  • Status changed from in progress to fixed
#8

Updated by libreuser 6 days ago

I-m sorry but I didnt solve it :(

Maybe Should i wait? right?

#9

Updated by bill-auger 4 days ago

  • Status changed from fixed to in progress

you are using the nonprism/icedove i686 maybe - i forgot about to upgrade nonprism/icedove

#10

Updated by bill-auger 4 days ago

nonprism/icedove 68.8.0-1.parabola3.nonprism1 also installs for me for x86_64 - your problem must be something different - if you are not using i686, can you post exact commands and error messages?

#11

Updated by libreuser 4 days ago

Now, error has changed:

LC_ALL=C pacman -Syyu
:: Synchronizing package databases...
 nonprism                    27.4 KiB   105 KiB/s 00:00 [#############################] 100%
 nonsystemd                  25.8 KiB   172 KiB/s 00:00 [#############################] 100%
 libre                      341.2 KiB  37.2 KiB/s 00:09 [#############################] 100%
 core                       121.7 KiB  57.1 KiB/s 00:02 [#############################] 100%
 extra                     1551.7 KiB  37.3 KiB/s 00:42 [#############################] 100%
 community                    4.7 MiB  75.0 KiB/s 01:05 [#############################] 100%
 pcr                        510.7 KiB   135 KiB/s 00:04 [#############################] 100%
:: Starting full system upgrade...
:: Replace icu-parabola with libre/icu-65-compat? [Y/n] 
warning: linux-libre: local (5.7.6-1) is newer than libre (5.7.2-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
*:: installing icedove (1:68.9.0-1.parabola1.nonprism1) breaks dependency 'icedove<1:68.8.1' required by icedove-extension-enigmail*

#12

Updated by bill-auger 3 days ago

thats great then - i just need to rebuild enigmail now

#13

Updated by bill-auger 3 days ago

  • Status changed from in progress to fixed

Also available in: Atom PDF