Project

General

Profile

Bug #2826

[calamares] GUI Installation halting

Dal - about 1 month ago - . Updated 30 days ago.

Status:
duplicate
Priority:
bug
Category:
Installer
Assignee:
% Done:

0%


Description

I tried installing the ISO 2019 LXDE openRC, however it stops. I have never seen this problem while installing parabola before. I'm not too advanced but I can work the issue out if I know how.
I found a similar issue in the forum but the solution was to use the CLI iso instead plus the post is 2 years old.


Files

install.log (44.6 KB) install.log Dal, 2020-07-03 01:02 AM
install.log (1.08 MB) install.log Dal, 2020-07-07 01:15 AM

History

#1

Updated by Megver83 about 1 month ago

  • Assignee set to bill-auger
  • Category set to Installer
  • Subject changed from GUI Installation halting to [calamares] GUI Installation halting

by looking at the logs I see that you're using the Systemd ISO and the Calamares Installer, right?

I'll assign this to bill-auger, then

#2

Updated by bill-auger about 1 month ago

yes i saw this - it is essentially a duplicate of #2033 -
off-hand, the problem is that the internet was enabled,
so the on-disk package cache was not used - that makes the
old 'unar' package unsatisfiable - the ISO should still work,
either by making sure the computer is not connected to the
internet, or by changing 'unar' to 'unarchiver', like:

$ sudo sed -i 's|unar|unarchiver|' /usr/share/calamares/modules/pacstrap-base.conf

i will look into it to make sure the systemd ISO is still viable,
or delete it

#3

Updated by Dal about 1 month ago

Thank you guys, I'm doing that right now.
(edit)installation requires internet. That string change with sed seems to be working

Btw, there are no attempts from the Parabola team to ditch systemD in the near future, right? I know Hyperbola ditched the linux kernel.

#4

Updated by bill-auger about 1 month ago

parabola is committed to staying as close to arch as possible,
within the FSDG - systemd is free software, and is the only
init-system in arch; so it must stay, if only for that reason -
additionally, parabola is committed to init-freedom, which
implies there are multiple init-systems/service-managers to
choose from - if parabola did not have systemd, then openrc
would be the only supported option, which would impede
init-freedom

#5

Updated by Dal about 1 month ago

Totally behind that premise :)

btw, the installation continued farther than before, but failed to update pacman keyring, I tried pacman-key --refresh-keys before installing but the error persists.
I will attach a new install log in a bit.

#6

Updated by Dal about 1 month ago

#7

Updated by bill-auger about 1 month ago

i did not get a chance to try this for myself yet - it may not be possible to install with the internet active - if it is possible, in order to do that, i think you would need to upgrade pacman manually, before starting the installer, because of the new .zst packages

appologies for the inconvenience - the calamares ISO needs to be replaced - i did not delete the one you are using. because some people with coreboot/libreboot can not boot the openrc ISOs - it should still be possible to install the system with the systemd ISO, if you ensure that the computer can not connect to the internet

if you have too much trouble with it, either of the openrc ISOs, and the talking ISO can be used to instead, to install manually

https://wiki.parabola.nu/Installation_Guide

#8

Updated by bill-auger 30 days ago

  • Status changed from unconfirmed to duplicate

Also available in: Atom PDF