Project

General

Profile

Bug #2937

texlive can't find some fonts during installation

MrXY - 2 months ago - . Updated about 2 months ago.

Status:
duplicate
Priority:
bug
Assignee:
% Done:

0%


Description

I tried to install and run LaTeX, but it complains about missing fonts. After running 'pacman -S texlive-most' (on a freshly updated system), it said lots of errors like "I can't find file `ecrm1000'." I attached the full output of the installation. (I tried to post short snippets of it here, but this website doesn't seem to allow me posting any output.)

After this, when I try to compile some simple documents with pdflatex, they fail with similar error messages. The example documents I tried and the output messages are in the attachments. The PDF output of the first one has no bullet points, only the text, and the second one is a Hungarian text with the standard Hungarian packages, and the generated PDF file has no text at all (blank white page).

I tried to think about ways I could solve this, but installing an official package on an updated system and getting error messages like this seems outside of my scope. I tried to search about this error on the Internet, and I found a similar Hyperbola bug and an Arch Linux one (see the links in the attachmant, I wasn't able to include them here), both are several years old, and the latter is said to be fixed.

(Ps. I struggled with the anti-spam system for hours to get this issue sent, and I almost gave up. I wonder how many bugs are lost because of this. Is it worth? As a developer, I always prefer having some spam than to risk losing any important feedback.)


Files

texlive-install.log (12 KB) texlive-install.log Output of installing texlive-most MrXY, 2020-11-24 11:36 AM
texlive-run1.log (2.07 KB) texlive-run1.log Output of compiling a simple document with itemize MrXY, 2020-11-24 11:37 AM
texlive-run2.log (2.21 KB) texlive-run2.log Output of compiling a simple Hungarian document MrXY, 2020-11-24 11:37 AM
links.txt (101 Bytes) links.txt URLs of similar bugs in Hyperbola and Arch Linux MrXY, 2020-11-24 11:37 AM

Related issues

Related to Packages - Bug #2151: [texlive-formatsextra] missing filesinfo needed

Actions
Is duplicate of Packages - Bug #2905: dollar sign \$ doesn't work in parabola texlivefixed

Actions

History

#1

Updated by bill-auger about 2 months ago

  • Status changed from unconfirmed to duplicate

texlive has alwys been somewhat troublesome - there have always been error messages; but they have not caused any problem - if the issue is missing fonts then those may be non-free

this is probably a duplicate of #2151 - please refer to that ticket for any discussion/news/progress

+

#2

Updated by bill-auger about 2 months ago

  • Related to Bug #2151: [texlive-formatsextra] missing files added
#3

Updated by oaken-source about 2 months ago

  • Assignee set to oaken-source
  • Status changed from duplicate to unconfirmed

I think this might have been closed prematurely. I'm taking a closer look, the minimal example you posted should be working, but I can reproduce the issue.

#4

Updated by bill-auger about 2 months ago

that is generally how i have been addressing reported problems with texlive: asking for an example test-case, and trying to make it work

i closed this ticket only as a 'duplicate' (not to indicate that it is resolved, or not-a-bug); as it seems to be echo-ing the same general concerns raise in #2151 -

IIRC both of these (and the linked forum thread https://labs.parabola.nu/boards/5/topics/55) were all WRT the 'ecrm1095' font

alextee looked into it at the time - his solution was to install something from the upstream - presumably that restored something that we remove

I solved this issue by installing texlive from here [link removed] EDIT: link removed since it seems that it contains non-free software

#5

Updated by oaken-source about 2 months ago

  • Is duplicate of Bug #2905: dollar sign \$ doesn't work in parabola texlive added
#6

Updated by oaken-source about 2 months ago

  • Status changed from unconfirmed to duplicate

this is actually cased by the same problem that causes the missing glyphs in #2905. closing as duplicate.

Also available in: Atom PDF