Project

General

Profile

Packaging request #2944

warning: cannot resolve "util-linux-libs", a dependency of "glib2" (package is missing on 32-bit parabola)

Drag0nFly - about 2 months ago - . Updated about 1 month ago.

Status:
open
Priority:
bug
Assignee:
-
% Done:

0%


Description

When performing a system upgrade today I encountered the above error message. It appears that this package has been renamed from its
predecessor libutil-linux, however the change is not visible on any 32-bit Parabola repos.

# pacman -Syyu
:: Synchronizing package databases...
 nonprism                                                                                                     23.7 KiB   286 KiB/s 00:00 [###################################################################################] 100%
 nonsystemd                                                                                                   33.5 KiB   440 KiB/s 00:00 [###################################################################################] 100%
 libre                                                                                                       320.8 KiB  1035 KiB/s 00:00 [###################################################################################] 100%
 core                                                                                                        125.6 KiB   816 KiB/s 00:00 [###################################################################################] 100%
 extra                                                                                                      1672.9 KiB  2.59 MiB/s 00:01 [###################################################################################] 100%
 community                                                                                                     4.7 MiB  8.47 MiB/s 00:01 [###################################################################################] 100%
 pcr                                                                                                         496.0 KiB  1653 KiB/s 00:00 [###################################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "util-linux-libs", a dependency of "glib2" 
:: The following package cannot be upgraded due to unresolvable dependencies:
      glib2

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'util-linux-libs' required by glib2

This package is not available for 32-bit arch:

pacman -sS util-linux-libs

returns nothing.

There has apparently been a change in naming convention, as the package "libutil-linux" does exist –

pacman -Q | grep util-linux
libutil-linux 2.35.1-1.nonsystemd1
util-linux 2.35.1-1.nonsystemd1

History

#1

Updated by doolio about 2 months ago

I can confirm the same error. Here is the output I get on my i686 machine.

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "util-linux-libs", a dependency of "glib2"
warning: cannot resolve "util-linux-libs", a dependency of "glib2"
warning: cannot resolve "util-linux-libs", a dependency of "glib2"
warning: cannot resolve "util-linux-libs", a dependency of "glib2"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libx264.so=160-32", a dependency of "ffmpeg"
warning: cannot resolve "libxkbcommon.so=0-32", a dependency of "mpv"
warning: cannot resolve "util-linux-libs", a dependency of "ndctl"
:: The following packages cannot be upgraded due to unresolvable dependencies:
ffmpeg glib2 mpv ndctl

#2

Updated by Drag0nFly about 1 month ago

The dependency for "util-linux-libs" appears to have been changed recently; as glib2 now installs. However, on my 2nd Parabola system (x86_64) the package has already been replaced.

pacman -sS util-linux-libs
nonsystemd/util-linux-debug 2.36-4.nonsystemd1
    Detached debugging symbols for util-linux
nonsystemd/util-linux-libs 2.36-4.nonsystemd1 [installed]
    util-linux runtime libraries
core/util-linux-libs 2.36.1-4 [installed: 2.36-4.nonsystemd1]
    util-linux runtime libraries

There is something strange going on with the i686 repos anyway, since more and more packages report that the locally installed versions (previously fetched from standard repos) are newer.

pacman -Syyu
:: Synchronizing package databases...
 nonprism                                                                                                     23.7 KiB   264 KiB/s 00:00 [###################################################################################] 100%
 nonsystemd                                                                                                   33.5 KiB   452 KiB/s 00:00 [###################################################################################] 100%
 libre                                                                                                       320.8 KiB   909 KiB/s 00:00 [###################################################################################] 100%
 core                                                                                                        126.1 KiB   824 KiB/s 00:00 [###################################################################################] 100%
 extra                                                                                                      1672.9 KiB  3.33 MiB/s 00:00 [###################################################################################] 100%
 community                                                                                                     4.7 MiB  8.90 MiB/s 00:01 [###################################################################################] 100%
 pcr                                                                                                         496.0 KiB  1817 KiB/s 00:00 [###################################################################################] 100%
:: Starting full system upgrade...
warning: cmake: local (3.19.1-2.0) is newer than extra (3.18.1-1.0)
warning: dnsmasq: local (2.82-2.0) is newer than extra (2.82-1.0)
warning: eudev: local (3.2.9-15) is newer than nonsystemd (3.2.9-1)
warning: eudev-libudev: local (3.2.9-15) is newer than nonsystemd (3.2.9-1)
warning: glib2-docs: local (2.66.3-1.0) is newer than core (2.64.4-1.0)
warning: libusb: local (1.0.23-2.0) is newer than nonsystemd (1.0.23-2.nonsystemd1)
warning: python: local (3.9.0-1.1) is newer than extra (3.9.0-1.0)
warning: rsync: local (3.2.3-1.0) is newer than extra (3.2.2-2.0)
warning: shadow: local (4.8.1-4.0) is newer than core (4.8.1-3.0)
warning: shntool: local (3.0.10-6) is newer than libre (3.0.10-5.parabola1)
resolving dependencies...
looking for conflicting packages...

Packages (1) glib2-2.64.4-1.0

Total Download Size:    2.80 MiB
Total Installed Size:  15.03 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n]
#3

Updated by doolio about 1 month ago

This is no longer an issue for me at least. I was able to perform a system upgrade.

Also available in: Atom PDF