Project

General

Profile

Bug #2946

Broken python packages after 3.9 upgrade

Drag0nFly - 9 months ago - . Updated 6 months ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

After the recent python 3.9 upgrade there are many packages which are not available for this version in the repos. These should be re-packaged in order to avoid breakage (preferably at the same time a new python version is made available)

Particularly certbot is quite critical.


Subtasks

Bug #2956: /usr/bin/python3: No module named Reflectorconfirmed

Actions

History

#1

Updated by Drag0nFly 9 months ago

This is for i686. (tried to edit the text, but there is no option for it.)

#2

Updated by oaken-source 9 months ago

Thanks for the report! There are indeed quite a few more of these candidates:

#3

Updated by oaken-source 9 months ago

by the way, some of the ones you mention above are not built by parabola.
In particular certbot is coming from arch. If you run the command above, you will see which packages from the core, community, extra repositories are outdated and need to be reported to archlinux32.

#4

Updated by bill-auger 9 months ago

  • Status changed from unconfirmed to confirmed
#5

Updated by bill-auger 9 months ago

Drag0nFly - you should be able to edit the OP - using the "reply" link, you should see an "edit" link beside "description" under "Change properties"

#6

Updated by doolio 9 months ago

I can confirm I have the same issue on my i686 machine.

#7

Updated by bill-auger 9 months ago

  • Assignee set to bill-auger
#8

Updated by bill-auger 9 months ago

  • Assignee deleted (bill-auger)
#9

Updated by bill-auger 9 months ago

of the lists added by Drag0nFly and doolio, only 'libre/python-markupsafe0' and 'nonsystemd/util-linux' are parabola packages - the list added by oaken-source was missing some repos

ive compiled a comprehensive list and deleted those other lists for clarity

libre/abiword
libre/ecasound
libre/hplip
libre/ogre
libre/opencv
libre/openshot
libre/paraboley-git
libre/python-django1.8
libre/python-django-countries
libre/python-django-jinja
libre/python-jsmin
libre/python-markdown2
libre/python-markupsafe0
libre/python-pgpdump
libre/python-psycopg2.6
libre/python-reportlab
libre/reflector
nonsystemd/util-linux
pcr/frescobaldi
pcr/gajim-plugin-omemo
pcr/geis
pcr/legit
pcr/libselinux
pcr/libsrs2-python
pcr/maildirproc
pcr/mathics
pcr/papis
pcr/pypolicyd-spf
pcr/python-arxiv2bib
pcr/python-bibtexparser
pcr/python-django18
pcr/python-efl
pcr/python-filetype
pcr/python-gensim
pcr/python-habanero
pcr/python-humblewx
pcr/python-hypersocial
pcr/python-isbnlib
pcr/python-libusb1
pcr/python-lirc
pcr/python-pefile
pcr/python-polib
pcr/python-poppler-qt5
pcr/python-py3dns
pcr/python-pycrypto
pcr/python-pylibgen
pcr/python-pyparser
pcr/python-pypump
pcr/python-pyspf
pcr/python-pystache
pcr/python-pyutil
pcr/python-pywebdav3
pcr/python-rosdistro
pcr/python-rosinstall
pcr/python-rospkg
pcr/python-sql
pcr/python-vcstools
pcr/python-wsgiref
pcr/python-wstool
pcr/python-xbee
pcr/searx
pcr/shogun
pcr/toot
pcr/xml2rfc
pcr/yafaray
#10

Updated by bill-auger 9 months ago

  • Description updated (diff)
#11

Updated by doolio 6 months ago

I can report that the vast majority of the i686 packages I had installed have been updated to use python 3.9. Those remaining relying on python 3.8 are:

community/python-jedi required by ipython python-language-server
extra/libibus required by sdl2
extra/libproxy required by glib-networking qt5-base

I presume these depend on the arch32 packages being updated?

Thanks for your time.

Also available in: Atom PDF