Project

General

Profile

Freedom Issue #2965

Freedom Issue #1167: [chromium][electron][qt5-webengine][qt6-webengine] QTWebgine/Electron embeds "entire Chromium platform"

[digikam]: depends on gt5-webengine

bill-auger - almost 2 years ago - . Updated over 1 year ago.

Status:
confirmed
Priority:
freedom issue
Assignee:
-
% Done:

0%


Description

another one bites the dust

$ digikam 
digikam: error while loading shared libraries: libQt5WebEngineWidgets.so.5: cannot open shared object file: No such file or directory

$ lddtree `which digikam`  | grep None
        libQt5WebEngineWidgets.so.5 => None
        libQt5WebEngineCore.so.5 => None

more precisely: "links to" - webengine is not in its dependency chain; because the dependency is satisfied in arch indirectly via 'marble-common' (which is rebuilt in [libre] to remove webengine support)


Related issues

Related to Packages - Freedom Issue #2117: [marble-common]: depends on qt5-webenginefixed

Actions

History

#1

Updated by bill-auger almost 2 years ago

  • Description updated (diff)
#2

Updated by bill-auger almost 2 years ago

#3

Updated by avalos over 1 year ago

Any progress on this? Will digiKam be removed or fixed?

Also available in: Atom PDF