Project

General

Profile

Hardware Support #2978

linux-libre-chromebook C201 support status

bill-auger - 7 months ago - . Updated 6 months ago.

Status:
open
Priority:
feature
Assignee:

Description

re: forum thread https://labs.parabola.nu/boards/17/topics/330 - this is to be a proper tracking ticket for on-going work toward stabilizing support for the chromebook C201

we would like to support the C201, but currently none of the parabola devs own one; so we need people to volunteer to use it regularly, and report any problems - a few have volunteered already - i have subscribed them to this ticket

  • mai
  • Time4Tea
  • BlockHtK
  • CBotulinum
  • nuclearkev (#dragora IRC - not registered on redmine)
  • danielp3344

it currently has its own wiki article
https://wiki.parabola.nu/Computers/Asus_Chromebook_C201

because this computer is capable of booting parabola with libreboot, it is deemed to be highly desirable from a software/hardware freedom perspective, and should be designated with high-priority support status - the eventual goal is to add it to the short list of well-supported "Recommended ARM Computers"; but it is not clear at this time, if it it still working
https://wiki.parabola.nu/Computers/Recommended_ARM_Computers

that list is related to ticket #2866

History

#1

Updated by oaken-source 7 months ago

last time I tried it, the parabola arm version worked out of the box on the C201. However, this device is increadibly fiddly to work with. I recall some weird issues with the boot loader, but once you got it booting, it was solid.

#2

Updated by bill-auger 7 months ago

the most common problem i remember was the graphics, showing only a white screen

#3

Updated by bill-auger 7 months ago

for reference, i have collected the previous issues and discussions related to the C201

the original ticket, which got it working:
https://labs.parabola.nu/issues/1965

the second ticket, which got it working again, after it broke:
https://labs.parabola.nu/issues/2372

various others:
https://labs.parabola.nu/issues/2158
https://labs.parabola.nu/issues/2161
https://labs.parabola.nu/issues/2261
https://labs.parabola.nu/boards/5/topics/297
https://labs.parabola.nu/boards/17/topics/330

#4

Updated by oaken-source 7 months ago

bill-auger wrote:

the most common problem i remember was the graphics, showing only a white screen

the white screen was an indicator for a boot failure

#5

Updated by Time4Tea 6 months ago

Hi, I just saw this ticket and wanted to post a reply. I have been actively using Parabola on a Chromebook C201 for a couple of years now. It's a great, lightweight laptop and I very much want to keep using it and help support efforts to improve Parabola support for it, where I can.

I admit I have been using it with the ALARM kernel and non-free firmware, so I can use the onboard Broadcom wifi chip. A couple of years ago, when I first got it, I also purchased a USB dongle from ThinkPenguin that is supposed to be supported by the libre kernel, but I have had all sorts of issues with it. If I plug it in and use it for a while, the performance seems quite flaky and it eventually seems to cause the whole system to crash. Therefore, the only working option I have right now for wifi is with the onboard Broadcom.

I have been trying to update the Parabola system on my C201 recently (last time I updated it was some time last year) and I am experiencing problems. I have copied my currently working (but outdated) system to a new partition and updated Parabola and the ALARM kernel (to 5.11.2). However, I am seeing issues with both the panfrost driver for the Mali GPU and the Broadcom wifi. When I try to log in, I see some graphical glitches with the lightdm greeter and if I switch to a different VT, there are a bunch of error messages being printed about 'unhandled page faults' with panfrost. However, I am able to log in eventually (I am using Mate), so it seems not to be too critical. So far, it seems that the Broadcom wifi chip is not working properly with the updated kernel, for some reason (from dmesg it seems to be having issues loading the firmware).

So, currently I have a working Parabola system, but I am not able to update it. Has anyone heard anything about hardware problems being introduced on armv7 with new versions of the kernel? I will be happy to try out some things, if anyone has any suggestions.

#6

Updated by Time4Tea 6 months ago

FYI: I tried updating my C201 system again today. I copied my working system to a new partition and tried updating just the userspace software, but without upgrading the kernel, kernel headers and firmware packages. The kernel version I have on the working system is 5.6.2.

The upgrade didn't go well, although the built-in Broadcom wifi was working. So, it seems that must have gotten broken in a recent kernel or firmware update. At first, it seemed there were still some problems with the panfrost driver, so I blacklisted that. However, I was still seeing some stability issues with the lightdm greeter. So, I configured systemd to boot straight into the CLI, which worked fine. From there I tried running startx /usr/bin/mate-session, but it wouldn't start. The Xorg log file has an error message saying:

Error: systemd-logind - unable to get session.

I have no idea what might be causing this. The system upgrade included over 500 packages, so it is very hard to know which one may have caused the problem. If anyone has any ideas, I would be happy to try some things out.

#7

Updated by bill-auger 6 months ago

  • Assignee set to Megver83
  • Description updated (diff)

Also available in: Atom PDF