Project

General

Profile

Bug #2981

Dependency issue with lib32-dbus

Time4Tea - 7 months ago - .

Status:
unconfirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

Hi, I am trying to upgrade my system and I am seeing a dependency issue relating to lib32-dbus. When I run pacman -Su, I get an error saying that 'lib32-dbus and dbus are in conflict'. It seems to be trying to install the 'multilib' version of lib32-dbus, rather then the 'nonsystemd' version; however, I have checked my pacman.conf and I have nonsystemd-multilib enabled above multilib.

The issue seems to be being caused by lib32-libpcap. The new version in the repo lists 'libdbus-1.so=3-32' as a dependency (which the old version didn't). This is provided by the 'multilib' version of lib32-dbus, but not the 'nonsystemd' version, so pacman is trying to install that one, which is conflicting with dbus.

Also available in: Atom PDF