Project

General

Profile

Bug #3058

Lime2 eMMC with Realtek RTL8211E PHY: Ethernet is not working

GNUtoo - 4 months ago - . Updated 3 months ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%

History

#1

Updated by GNUtoo 4 months ago

libre/uboot4extlinux-a20-olinuxino-lime2-emmc version Kernel Working
2021.07-2 linux-libre 5.11.2-1 Probably not1
linux-libre-lts 5.10.19-1 Probably not1
2020.04-1 linux-libre 5.11.2-1 Probably not1
linux-libre-lts 5.10.19-1 Probably not1
before the big rework2 linux-libre 5.11.2-1 Probably not1
linux-libre-lts 5.10.19-1 Probably not1

However I recall that at some point it stopped working, and upgrading u-boot made it work again at that point, but now that doesn't work anymore. So something in newer kernels probably required newer u-boot and now maybe even newer kernels broke it, or maybe my board is broken (I still need to test it with older images and/or other distributions (like GuixSD)).

1 I need to re-test to be 100% sure.
fn2. 89ab0d27c libre: uboot4extlinux-sunxi: lower maintenance costs

#2

Updated by bill-auger 3 months ago

  • Status changed from unconfirmed to confirmed

the title specifies EMMC - does this bug not affect non-emmc models? - it is the same PHY device

#3

Updated by GNUtoo 3 months ago

I've confirmed the bug: I still had a microSD with an older Parabola image that worked fine.

It most probably affect non eMMC models as well but I don't have one so I can't tell.

The person who bugreported for the newer phy not working has several models but I don't recall which ones. That person could probably do some tests since she got some of them for solving the phy issues by doing tests.

#4

Updated by GNUtoo 3 months ago

Here's the software versions on the working image:

Software String at boot on the serial port package version
u-boot U-Boot 2019.10-1 (Nov 11 2019 - 02:25:01 +0000) Parabola GNU/Linux-libre libre/uboot4extlinux-a20-olinuxino-lime2-emmc 2020.04-1
linux-libre 5.8.13-gnu-1 libre/linux-libre 5.8.13-1

Also available in: Atom PDF