Project

General

Profile

Bug #3117

[texlive-bin] needs to be rebult against poppler 21.10.0-1

kranos86 - 11 months ago - . Updated 11 months ago.

Status:
duplicate
Priority:
bug
Assignee:
-
% Done:

0%


Description

  • steps to reproduce:
    1) # pacman -Syu poppler
  • expected result:
    I expect poppler to update from 21.09.0-1 => 21.10.0-1.
  • actual result:
    Instead, pacman prints: "installing poppler (21.10.0-1) breaks dependency 'poppler=21.09.0-1' required by texlive-bin" won't update poppler.

History

#1

Updated by nona 11 months ago

  • Status changed from unconfirmed to confirmed

This is just a thought, but I cannot confirm it: I think that this kind of issues arise, because the maintainer of a given package builds the package which she/he/X maintains, and it works on her/his/X machine. The person updates the package to the repositories, but it breaks everyone else's system.

It may also be that the repositories are being updated at the moment, but I would think that the repositories are synchronised. I get the same (or worse) error:

pacman -S poppler

LANG=C LANGUAGE=C sudo torsocks pacman -S poppler
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing poppler (21.10.0-1) breaks dependency 'poppler=21.09.0' required by poppler-glib
:: installing poppler (21.10.0-1) breaks dependency 'poppler=21.09.0' required by poppler-qt5
:: installing poppler (21.10.0-1) breaks dependency 'poppler=21.09.0-1' required by texlive-bin

also,
pacman -Qi poppler

Name            : poppler
Version         : 21.09.0-1

If this is very important, I would recommend to build the package by yourself on your machine by following (or adapting) the PKGBUILD posted on https://www.parabola.nu/packages. Another work-around is to avoid the installation of the packages which break, but that is an oxymoron in a rolling distro :P ! I hope someone with a nicer badge helps with a long-term solution.

Good luck.

#3

Updated by dllud 11 months ago

Pavel, poppler comes directly from Arch.
Though, the package that needs to be rebuilt is texlive-bin and its descendants.
This is a recurring task that maintainers track at #2546
Let's hope they can rebuild it soon.

#4

Updated by bill-auger 11 months ago

  • Status changed from confirmed to duplicate

texlive-bin 2021.58686-3.parabola8 fixes this today

texlive-bin must be re-built often, due to fast-moving poppler - there is a permanent open 'epic' ticket, which we prefer to re-use: #2546, and a volatile sub-task, which is re-opened and closed as needed: #2776

please watch that one, and bump it in the future, anytime you get: "installing poppler (N) breaks dependency"

Also available in: Atom PDF