Project

General

Profile

Bug #3175

pandoc: error while loading shared libraries: libHSzip-archive-0.4.1-DJkoFZ5OWm8Cw5Ds4ctvh6-ghc9.0.2.so: cannot open shared object file

maddox - 7 months ago - . Updated 6 months ago.

Status:
duplicate
Priority:
bug
Assignee:
-
% Done:

0%


Description

I have upgraded correctly, and I think that package definitions are not good that I am getting too many problems, and programs stop working.

After the manual installation of haskell-zib-archive, then I get error:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStexmath-0.12.3.2-2FRxbuFZIE951s24Gspfbq-ghc9.0.2.so: cannot open shared object file: No such file or directory

But I don't expect those kinds of errors. I was using pandoc without problems, upgraded system, and it appears that required packages for pandoc have not been installed.

Are those packages in dependency list? It looks so, but they are not installed or downloaded when pandoc is installed.

Then again:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStagsoup-0.14.8-60SLYpclrPx2RfFF3OglKr-ghc9.0.2.so: cannot open shared object file: No such file or directory

and if I do following:

sudo pacman --sync --refresh --needed pandoc
:: Synchronizing package databases...
nonsystemd
nonsystemd is up to date libre
libre is up to date core
core is up to date extra
extra is up to date community
community is up to date pcr
pcr is up to datewarning: pandoc-2.14.2-14 is up to date -- skipping
there is nothing to do

Then I have installed haskell-skylighting:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSskylighting-core-0.11-2nqbxjdARqdFnNwl2QPqkd-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then I have installed haskell-skylighting-core, and then:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSutf8-string-1.0.2-AOWVLBhuvp8IuetdNwScv2-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after installation of haskell-utf8-string, then I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSansi-terminal-0.11-EGqiRilu5fLIxBsfMBVBk8-ghc9.0.2.so: cannot open shared object file: No such file or directory

then again:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHScolour-2.3.6-1Gqs1ZCmQ6j2500b2gSlIV-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after installation of haskell-colour, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSjira-wiki-markup-1.4.0-ARhTkoqdQraLQQT7enUENC-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after installation of haskell-jira-wiki-markup, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSipynb-0.1.0.1-GtfDHOt53jJCWbHv81PhER-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after installation of haskell-ipynb, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShttp-client-tls-0.3.5.3-3NtZIGwIXlDKzSbi7ikppj-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after manual installation of haskell-http-client-tls, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShttp-client-0.7.10-7x9wXTpLTFfwDClQVfVWJ-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after manual installation of haskell-http-client, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSiproute-1.7.12-5OYMJ79Q38mKyms7hQCtuR-ghc9.0.2.so: cannot open shared object file: No such file or directory

then after manual installation of haskell-iproute, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShttp-types-0.12.3-9Uvs22j5d3n7gOEM6LGSbZ-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after manual installation of haskell-http-types, I get:

But this does not work automatically:

sudo pacman --sync --refresh --needed pandoc

:: Synchronizing package databases...
nonsystemd
nonsystemd is up to date libre
libre is up to date core
core is up to date extra
extra is up to date community
community is up to date pcr
pcr is up to datewarning: pandoc-2.14.2-14 is up to date -- skipping
there is nothing to do

Then after manual installation of haskell-hslua-module-text, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShslua-module-system-0.2.2.1-3REDJuqUUsR2r9r7Ubj4eE-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after manual installation of haskell-hslua-module-system, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStemporary-1.3-GJoonVnRq6AE0Uafd81c0-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after manual installation of haskell-temporary, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShslua-module-path-0.1.0.1-4CPa0WBAf0k3gfVcLR3C9H-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after manual installation of haskell-hslua-module-path, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShslua-1.3.0.1-33lvptssIDdGbrIdNH75ve-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after manual installation of haskell-hslua-module-path, following:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShaddock-library-1.10.0-IJLHBmlTGZxDaoFaPprt4U-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-haddock-library, I get:

pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSdoctemplates-0.10.0.1-CwcEmlWrmmufIYDdaL6o5-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-doctemplates, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStext-conversions-0.3.1-6VVMhX0zL2cJIZr15IurJh-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-text-conversions, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSbase16-bytestring-1.0.2.0-GqhdS8SZiULHJmCgO1KrYc-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-base16-bytestring, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSdoclayout-0.3.0.2-83FIXKBN7K3EL4IjEwDrwV-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-doclayout, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSconnection-0.3.1-LgxkXkmYwUsH1fZ3VJXsId-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-connection, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSx509-system-1.6.6-AIin9GoO67uJVmaLJvEqvY-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-x509-system, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStls-1.5.6-5GhHwD9DqtNADiMaAcbiLH-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-tls, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSx509-validation-1.6.12-8vUSOVgnFNu4xdKdxZLhZt-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-x509-validation, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSx509-store-1.6.7-9RDOhivAbfUCO7JXQoIMUF-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-x509-store, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSx509-1.7.5-5mgnPGlHifsBKUuNJplVO2-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-x509, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSpem-0.2.4-1AE0EJJAAtkDxY7d7tlqHq-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-pem, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSasn1-parse-0.9.5-20Ag8y7ojBz8DD6lSWGacF-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after installing haskell-asn1-* packages:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHScryptonite-0.29-1qpuHkCrZkQ7nPLQsly6pE-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-cryptonite, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShourglass-0.2.12-6JmhmDJx3sR46pTCzTkXqF-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-hourglass, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSsocks-0.6.1-EtBe4gto5PyI5nGpUOsaoO-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after haskell-socks, and other packages, I get:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHScommonmark-pandoc-0.2.1.1-2apMNga88rcBsjVPOIRwgD-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after installing all haskell commonmark packages, and after network packages, unicode transforms, network, haskell-citeproc, then I am asking why is that all not automatic?


Related issues

Related to Packages - Bug #2823: [pandoc] Looks wrong shared library versionunconfirmed

Actions

History

#1

Updated by maddox 7 months ago

I have copied all dependent packages and tried this:

sudo pacman --sync --refresh --needed ghc-libs haskell-juicypixels haskell-sha haskell-aeson haskell-aeson-pretty haskell-attoparsec haskell-base64-bytestring haskell-blaze-html haskell-blaze-markup haskell-case-insensitive haskell-citeproc haskell-commonmark haskell-commonmark-extensions haskell-commonmark-pandoc haskell-connection haskell-data-default haskell-doclayout haskell-doctemplates haskell-emojis haskell-file-embed haskell-glob haskell-haddock-library haskell-ipynb haskell-jira-wiki-markup haskell-skylighting haskell-skylighting-core haskell-hslua haskell-hslua-module-path haskell-hslua-module-system haskell-hslua-module-text haskell-http-client haskell-syb haskell-hsyaml haskell-http-client-tls haskell-http-types haskell-safe haskell-split haskell-texmath haskell-network haskell-pandoc-types haskell-random haskell-scientific haskell-tagsoup haskell-temporary haskell-text-conversions haskell-network-uri haskell-unicode-collation haskell-unicode-transforms haskell-unordered-containers haskell-zip-archive haskell-xml haskell-xml-conduit haskell-zlib

and I got this:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSconduit-extra-1.3.5-SMZSq8bs5LIqLcngybAFx-ghc9.0.2.so: cannot open shared object file: No such file or directory

then again:
$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStyped-process-0.2.8.0-BbYLNBPt5FyDi4CoGrS4C7-ghc9.0.2.so: cannot open shared object file: No such file or directory

then:

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSstreaming-commons-0.2.2.2-BJwC9Gf0E5yI0EiAxGqXTa-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSasync-2.2.3-7dU5xBGJ0r25BBoBwSM8pO-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSconduit-1.3.4.2-wvTpsnmPqmANAZpcwNsbP-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSresourcet-1.2.4.3-IYdbpd4XI0dEE8sxS3PVDo-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSmono-traversable-1.0.15.3-syJ1XDbqPbBZTPAsbm6AV-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSvector-algorithms-0.8.0.4-BbyySLoGe8ZBk2NnvbC1pn-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSuniplate-1.6.13-10Zi4GJry9QA8NYRoRhxvk-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSth-lift-instances-0.1.19-9lP4vPehctpBhJFq4QjtUz-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSQuickCheck-2.14.2-AnpTXeivrkiLIdamjGWtyr-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSuuid-types-1.0.5-p6XKwEL6vRDVerfZiNWE3-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSsplitmix-0.1.0.4-KcWuCdLOJdQC3CqelXlR2L-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHStime-compat-1.9.6.1-1Z4gOwgOgYuFPrTFKyRCo1-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSstrict-0.4.0.1-ICxOA0d9XjF1xxu1cW9own-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSthese-1.1.1.1-BNPJUFkhYy5HBXwh8ijjSk-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSassoc-1.0.2-6PNIYx2hC9eG93xW2ewLhW-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSbifunctors-5.5.11-Cd91CVeBuoc7LKSbtuiyyt-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHScomonad-5.0.8-EUkMUF71D86HiL36eB28Ke-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSdistributive-0.6.2.1-1dnZXO49YwPFK0a7YrWfs0-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSbase-orphans-0.8.5-9CO98S38s8N9I6X76hRWN7-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSdata-fix-0.3.2-9Fp2aIePFOPFY6KyzkE5Cw-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSbase-compat-batteries-0.11.2-LiuW5pMYwkdIq5XCI0H615-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHShashable-1.3.5.0-6AeYBBukoSPGSG8LxP8orZ-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSvector-0.12.3.1-IPjkfAE3hEhDt08GLG1iXV-ghc9.0.2.so: cannot open shared object file: No such file or directory

$ pandoc
/usr/bin/pandoc: error while loading shared libraries: libHSprimitive-0.7.3.0-6wYQtSKx96uH7VCWNeklkU-ghc9.0.2.so: cannot open shared object file: No such file or directory

Then after installing it all manually, it worked.

Either I am installing it by wrong method, or package dependencies are wrong, or something else.

#2

Updated by bill-auger 6 months ago

  • Status changed from unconfirmed to duplicate

duplicate of #2823

#3

Updated by bill-auger 6 months ago

  • Related to Bug #2823: [pandoc] Looks wrong shared library version added

Also available in: Atom PDF