Project

General

Profile

Freedom Issue #3195

Consider providing eudev as an alternative to udev

Drag0nFly - 6 months ago - . Updated 5 months ago.

Status:
duplicate
Priority:
bug
Assignee:
-
% Done:

0%


Description

As we all know, the Gentoo maintainer for this project and hwids caused this package to become orphaned. However, eudev is still being maintained outside of Gentoo (https://github.com/eudev-project/eudev/releases), and the project is not dead with the recent version at 3.2.11.

As someone who switched to Parabola due to their focus on freedom for init-systems – as well as greater control over packages repositories (nonprism etc) – I find it very important to be able to continue using a slimmed-down version of udev and not the bloatfest introduced by systemd.

eudev can be built with a dependency towards “hwdata” instead of the (now-defunct) “hwids” in order to prevent udev from being automatically pulled in.


Related issues

Related to Documentation - Housekeeping #3168: [eudev-systemd]: package dropped - still suggested on the wikiopen

Actions

History

#1

Updated by gap 5 months ago

I suggested this in #3168, as such this ticket is a duplicate.

#2

Updated by Drag0nFly 5 months ago

Sorry for the dupe (issue was not noticed before I submitted) – this ticket can then be deleted.

#3

Updated by bill-auger 5 months ago

  • Related to Housekeeping #3168: [eudev-systemd]: package dropped - still suggested on the wiki added
#4

Updated by bill-auger 5 months ago

  • Status changed from unconfirmed to duplicate

duplicate of #3168

Also available in: Atom PDF