Project

General

Profile

Bug #3336

[python-mistune] and [python-mistune1] are in conflict

anonymous - about 1 month ago - . Updated 2 days ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

0%


Description

When trying to update the system, I get a package conflict error.
Now I have package "python-mistune1 0.8.4-4" as dependence of "pcbdraw 0.6.1-3" package. Pacman want install new package "python-mistune 2.0.4-1" as dependence "jupyter-nbconvert 7.0.0-2" as dependence "spyder 5.3.2-2". These packages conflict among themselves.

$ sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: python-mistune and python-mistune1 are in conflict. Remove python-mistune1? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python-mistune1 breaks dependency 'python-mistune1' required by pcbdraw

History

#1

Updated by anonymous about 1 month ago

I forgot to report that Architecture: x86_64

#2

Updated by bill-auger about 1 month ago

  • Status changed from unconfirmed to forwarded upstream

the same conflict is present on arch

im not certain if this is a bug or not - the situation is not common;
but it could be that some high-level applications can not coexist -
i asked upstream

https://bugs.archlinux.org/task/75780

#3

Updated by bill-auger about 1 month ago

ok so that conflict is going to remain for a while - it will not be possible to keep both 'spyder' and 'pcbdraw' installed at the same time, until the 'pcbdraw' developers can resolve this BR https://github.com/yaqwsx/PcbDraw/issues/103 - 'pcbdraw' is requiring a much older version of 'python-mistune'; and is in danger of being dropped from arch because of that, because all other dependents of 'python-mistune' have moved forward

if you must keep both installed, just do not upgrade the system until the problem is resolved - if you are a programmer, maybe you could help the 'pcbdraw' developers to become compatible with the newer 'python-mistune'

#4

Updated by anonymous 25 days ago

Ok, I understand. So far I add package "jupyter-nbconvert" to the section IgnorePkg in /etc/pacman.conf

#5

Updated by bill-auger 2 days ago

  • Assignee set to bill-auger

the conflict is resolved in arch - pcbdraw and python-mistune1 were dropped

#6

Updated by bill-auger 2 days ago

  • Status changed from forwarded upstream to fixed

Also available in: Atom PDF