Project

General

Profile

Bug #3435

boost-libs breaks a dependency required by blender

direnis - 3 days ago - . Updated 1 day ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

  • steps to reproduce:
    .# pacman -Syu
  • expected result:
    pacman performs a system upgrade without any issues
  • actual result:
      
    $ LANG=C doas pacman -Syu
    doas (user@host) password: 
    :: Synchronizing package databases...
     nonprism is up to date
     libre is up to date
     core is up to date
     extra is up to date
     community is up to date
     pcr is up to date
     multilib is up to date
    :: Starting full system upgrade...
    warning: python-charset-normalizer: ignoring package upgrade (2.1.1-1 => 3.0.1-1)
    warning: python-matrix-nio: ignoring package upgrade (0.19.0-4 => 0.20.0-1)
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: installing boost-libs (1.81.0-2) breaks dependency 'libboost_locale.so=1.80.0-64' required by blender
    :: installing kded (5.102.0-1) breaks dependency 'kded=5.101.0' required by kio
    $ 
    

History

#1

Updated by bill-auger 1 day ago

  • Status changed from unconfirmed to confirmed

the last time blender needed a rebuild, it also could have been upgraded; but the latest version did not compile - i rebuilt the previous version instead - this time, neither version will compile

Also available in: Atom PDF