Project

General

Profile

Bug #828

[redmine] deprecation warning while starting

fauno - over 4 years ago - . Updated almost 2 years ago.

Status:
fixed
Priority:
critical
Assignee:
-
% Done:

100%


Description

Passenger is writing lots of errors into /tmp, sometimes filling it and preventing other scripts using /tmp from working.

The error is

`[DEPRECATION] requiring "RMagick" is deprecated. Use "rmagick" instead`

Maybe redmine requires an upgrade?

History

#1

Updated by fauno over 4 years ago

by fetching sources on /srv/http/labs.parabola.nu i see there's a new version, we're at 3.0.1 and there's 3.1.1 available

#2

Updated by Anonymous over 4 years ago

  • Assignee set to Anonymous
#3

Updated by mtjm over 4 years ago

Please backup before upgrade.

Can we configure logging so deprecation warnings won't be written?

#4

Updated by Anonymous over 4 years ago

  • Subject changed from Deprecation warning while starting redmine to [redmine] deprecation warning while starting
#5

Updated by Anonymous over 4 years ago

  • Status changed from open to in progress
#6

Updated by Anonymous over 4 years ago

  • % Done changed from 0 to 90

redmine-3.1.1-1 pushed, check now if deprecation warning doesn't shows anymore

#7

Updated by mtjm over 4 years ago

We have 3.0.1 running (see https://labs.parabola.nu/admin/info). I can update unless we decide to migrate to the pcr package.

#8

Updated by Anonymous about 4 years ago

  • Assignee deleted (Anonymous)
#9

Updated by lukeshu almost 4 years ago

  • % Done changed from 90 to 100
  • Status changed from in progress to fixed

This hasn't happened since October.

#10

Updated by bill-auger almost 2 years ago

this warning still appears in the console every time bundler, rails, or a rake task is run

Also available in: Atom PDF