Project

General

Profile

Bug #2576

Updated by bill-auger 4 months ago

i have not been able beenable to reproduce any of the other conflicts reported with installing or upgrading openrc, by using pacman- Syu; but i may have been missing mssing some of the essential desktop packages

as of today, the most basic essential openrc install is:
<pre>
base system:
base systemd-libs-dummy
desktop system:
base systemd-libs-dummy
openrc-desktop systemd-dummy polkit-elogind
</pre>

when i tried installing all of those, i hit another set of conflicts that are unlike the others

<pre>
$ sudo pacman -S base systemd-libs-dummy openrc-desktop systemd-dummy polkit-elogind --needed
warning: systemd-libs-dummy-1:1-1 is up to date -- skipping
warning: acpid-openrc-20170927-1 is up to date -- skipping
warning: alsa-utils-openrc-20170927-1 is up to date -- skipping
warning: avahi-openrc-20170927-1 is up to date -- skipping
warning: bluez-openrc-20170927-1 is up to date -- skipping
warning: displaymanager-openrc-20170927-1 is up to date -- skipping
warning: gpm-openrc-20170927-1 is up to date -- skipping
warning: modemmanager-pk-rules-20160402-1 is up to date -- skipping
warning: wpa_supplicant-openrc-20170927-1 is up to date -- skipping
:: There are 2 members in group openrc-desktop:
:: Repository pcr
1) elogind-openrc 2) networkmanager-openrc

Enter a selection (default=all):
warning: systemd-dummy-1:1-1 is up to date -- skipping
resolving dependencies...
looking for conflicting packages...
:: polkit-elogind and polkit are in conflict. Remove polkit? [y/N] y
:: elogind-openrc and elogind are in conflict. Remove elogind? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'elogind' required by elogind-openrc
:: unable to satisfy dependency 'elogind' required by polkit-elogind
:: removing elogind breaks dependency 'elogind' required by networkmanager
</pre>

Back