Project

General

Profile

Bug #2581

Updated by bill-auger about 2 months ago

libre/mplayer and other programs have has unmet dependencies - they are installed but no longer in the repos

<pre>
$ sudo pacman -Syu
....
:: installing xorgproto (2019.2-2) breaks dependency 'dmxproto' required by libdmx
:: installing xorgproto (2019.2-2) breaks dependency 'xf86dgaproto' required by libxxf86dga

$ pacman -Ss dmxproto
$ pacman -Ss xf86dgaproto
$ pacman -Ss libdmx
$ pacman -Ss libxxf86dga

$ pacman -Qi libdmx | grep -E 'Depends|Required'
Depends On : dmxproto libxext
Required By : xorg-server-xdmx xorg-xdpyinfo

$ pacman -Qi libxxf86dga | grep -E 'Depends|Required'
Depends On : libxext xf86dgaproto
Required By : mplayer xorg-xdpyinfo

# pacman -R libdmx libxxf86dga
....
:: removing libxxf86dga breaks dependency 'libxxf86dga' required by mplayer
:: removing libdmx breaks dependency 'libdmx' required by xorg-server-xdmx
:: removing libxxf86dga breaks dependency 'libxxf86dga' required by xorg-xdpyinfo
:: removing libdmx breaks dependency 'libdmx' required by xorg-xdpyinfo

# pacman -R libdmx libxxf86dga mplayer xorg-server-xdmx xorg-xdpyinfo
# pacman -S mplayer
....
:: unable to satisfy dependency 'libxxf86dga' required by mplayer

</pre>

Back