Project

General

Profile

Bug #1517

[gnome-boxes] depends on nonexistent package [libtracker-sparql] cannot be installed

ToffeeYogurtPots - almost 3 years ago - . Updated almost 3 years ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

100%


Description

Tested on multiple machines and one near-stock virtual machine. Seems like gnome-boxes dependencies are outdated. Arch's package doesn't even depend on libtracker-sparql: https://www.archlinux.org/packages/community/x86_64/gnome-boxes/

Steps to reproduce:
  1. Run "pacman -S gnome-boxes".
[user@hostname ~]$ sudo pacman -S gnome-boxes
[sudo] password for user: 
resolving dependencies...
warning: cannot resolve "libtracker-sparql", a dependency of "gnome-boxes" 
:: The following package cannot be upgraded due to unresolvable dependencies:
      gnome-boxes

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do

History

#1

Updated by isacdaavid almost 3 years ago

  • Assignee set to isacdaavid
  • Status changed from open to in progress
#2

Updated by isacdaavid almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from in progress to fixed

it had not even been 3 weeks since i last updated to the latest version in Arch, which still was 3.24 at the time

anyway, this should be fixed now. wait a bit before 3.26 shows up in mirrors.

#3

Updated by ToffeeYogurtPots almost 3 years ago

isacdaavid wrote:

it had not even been 3 weeks since i last updated to the latest version in Arch, which still was 3.24 at the time

anyway, this should be fixed now. wait a bit before 3.26 shows up in mirrors.

Thanks for fixing it. I'll try it later when it's dispersed across the mirrors. Forgive my ignorance but is there no way to automate dependency changes? I'd imagine it would make things a lot easier.

Also available in: Atom PDF