Project

General

Profile

Bug #1570

[libre/hplip] missing "*.PPD" file for HP LaserJet 400 M401n.

ToffeeYogurtPots - over 2 years ago - . Updated over 2 years ago.

Status:
not-a-bug
Priority:
bug
Assignee:
-
% Done:

0%


Description

This issue is present on both Parabola and Arch. I can confirm that it does work with the free HPLIP driver as it works on Trisquel 7.0, is listed here https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index and a very similar model (with almost identical formatter board) appears on h-node where it is confirmed to work with Trisquel 5.5 https://h-node.org/printers/view/en/717/LaserJet-Pro-400-M401dn/1/1/undef/undef/undef/Ethernet/compatibility/undef

Steps to reproduce:
1. Attempt to set-up HP LaserJet 400 M401n via 'hp-setup'.
2. Click 'next' once it discovers your device.
3. 'hp-setup' will fail to find the "*.PPD" file and prompt the user to manually select it, though it does not exist. There is "hp-laserjet_400_m401dne-ps.ppd.gz" but this is incompatible with the M401n.

'hp-setup' output:
error: No PPD found for model laserjet_400_m401 using old algorithm.
error: No appropriate print PPD file found for model hp_laserjet_400_m401n
error: No PPD found for model laserjet_400_m401 using old algorithm.
error: No appropriate print PPD file found for model hp_laserjet_400_m401n

History

#1

Updated by ToffeeYogurtPots over 2 years ago

Just noticed that the /usr/share/ppd/hplip/HP/ directories are very different between Parabola and Trisquel. On Parabola there seems to be a '*.ppd' file for every supported printer whereas on Trisquel there is only 8 '*.ppd' files. Yet on Trisquel my printer works fine.

#2

Updated by oaken-source over 2 years ago

  • Status changed from open to not-a-bug

Also available in: Atom PDF