Packaging Request #2148

[ruby]: broken x86_64 and i686

bill-auger - over 3 years ago - . Updated over 3 years ago.

% Done:



$ anything-that-usess-ruby
Traceback (most recent call last):
    1: from <internal:gem_prelude>:2:in `<internal:gem_prelude>'
<internal:gem_prelude>:2:in `require': cannot load such file -- rubygems.rb (LoadError)



Updated by bill-auger over 3 years ago

some essential ruby-ish binaries were moved into different packages (rubygems, irb, rdoc, ri, rake) - this probably just needs an upgrade to v2.6, though there could be a dependency cascade with 'ruby-*' re-packaged gems

just to note: a 'ruby2.5' package has been added to arch, but its only dependent is 'gitlab'


Updated by freemor over 3 years ago

I was looking into this a bit.. Wanting to understand the need for the Libre package, understand what the patches do etc.

In such I saw that the original issue was from 4 years ago and that a bug re licensing had been filed with the ruby folks. After diving through a rats nest of "related" to and "re-opened as" type threads I'm getting the impression that the ruby folks consider this fixed and closed. If that is indeed the case we may be able to just un-libre the ruby package and save future time and effort

for reference see:


Updated by bill-auger over 3 years ago

  • Priority changed from bug to broken
  • Tracker changed from Bug to Packaging Request

ok i looked into it more on our side - thre are currently 3 ruby packages on the blacklist

ruby2.3:ruby2.3:parabola:674:[semifree] json module has nonfree CVTUTF code; replace with pure Ruby implementation
ruby-docs:ruby-docs:parabola:674:[semifree] Rebuilt as part of 'ruby' package
ruby:ruby:parabola:674:[semifree] json module has nonfree CVTUTF code; replace with pure Ruby implementation

today, arch does not have a package for 'ruby2.3'; so that one is an orphan entry and should be removed

columns 3 and 4 of the blacklist entries indicate that these are all there for exactly the same reason - namely, the parabola bug report #674

one year ago lukeshu noted in that BR that this issue was expected to be resolved soon - pointing to two different upstream BRs

from what evidence there is now, it appears that the ruby developers had solved this believe licensing issue in ruby itself

but the JSON ruby gem (that is shipped along with ruby?) may still contain one (ext/json/generator/generator.c) - it looks like all they need to do is to drop in the updated replacement file which is FSDG compliant; but it's developers seem to have ignored the request to update the generator.c

lukeshu bumped that BR on Jun 23, 2017 and again on Jul 4, 2017; but the file in question has not been modified since Apr 18, 2017 - so probably the blacklisting is still necessary - maybe lukeshu remembers more about this


Updated by freemor over 3 years ago

Well from what I saw in the link I referenced it looked like the Ruby-lang folks felt they had cleaned up the json/UTF licensing thing.

Not sure what the issue with ruby-doc would be or if it is just part of the split package.. Anyways... Probably best for Someone Familiar with the issue to have a look or chat with the ruby-lang folks.

If not we ran always pull ruby2.6 into libre-testing and get it patched and out the door.


Updated by bill-auger over 3 years ago

here freemor

that says ruby itself is not the problem - the JSON library is not an official project and an issue was opened to that upstream as suggested - that dev paid it no attention and the file (ext/json/generator/generator.c) has not been changed


Updated by freemor over 3 years ago

Thanks. Guess I missed that one while spiraling through all the related/see/moved to/re opened as/etc.


Updated by bill-auger over 3 years ago

bumped the upstream bug report - yet no reply


Updated by bill-auger over 3 years ago

i have removed the now obsolete 'ruby2.3'/'ruby2.3-debug' from x86_64 and arm - those and 'ruby2.3-bundler' are/were required only by gitlab and that is currently still the case only in i686 - gitlab is not built for arm and the current gitlab for x86_64 requires the ruby2.5 counterparts of these packages - again, those exist only for the sake of gitlab - ruby2.5 has been added to the the blacklist - that means 'gitlab' will not be installable or upgradable (blacklisted by proxy)

the current parabola 'ruby' package could probably be re-built as 'ruby2.5' to satisfy gitlab (or not)

we should remember to remove the remaining 'ruby2.3'/'ruby2.3-debug' package from i686, and the blacklist entry, once i686 upgrades their 'ruby'


Updated by bill-auger over 3 years ago

i still have no idea what the intermediate tarball was for - but erm ... so we dont do that anymore - i modified the PKGBUILD to patch everything in place in the normal way for now - maybe someday will will discover why those repackaged 'ruby-libre' tarballs are on the server

x86_64 and i686 are built and working - spinning the wheel for arm now


Updated by bill-auger over 3 years ago

  • Assignee set to bill-auger

Updated by bill-auger over 3 years ago

  • Status changed from open to fixed

Also available in: Atom PDF