Project

General

Profile

Bug #2537

openrc gui installer is broken

alextee - 12 days ago - . Updated about 15 hours ago.

Status:
confirmed
Priority:
bug
Category:
Installer
Assignee:
% Done:

0%


Description

i tried installing parabola using this
https://wiki.parabola.nu/Get_Parabola#Parabola_OpenRC_LXDE_ISO

here are some things i noticed:

the first thing i noticed is that double clicking the installation icon doesn't work because termx is not installed. manually installing termx fixed this.

then, iceweasel doesn't open when you select it from the menus, so there is no browser by default and that kinda sucks.

when i ran the installer after installing termx the installation process was not clear at all from the GUI - I have 2 partitions: /home and /, and the installer just goes on installing things without asking me where to install. I later found out through the guides that you have to set the boot flag. still, the gui installer didn't work. I couldn't boot, all i had was a grub rescue screen. anyway, looking at the guides i managed to proceed using the command line and ignored this installer.

i am trying to install an openrc system with a desktop manager preinstalled, and after some troubleshooting i found that this command worked for me for bootstrapping the root partition - in case anyone wants to give it try:
pacstrap /mnt base-openrc systemd-libs-dummy openrc-desktop systemd-dummy polkit-elogind grub lxde lightdm xorg-server xorg-apps vim nano linux-libre sed

note that the tutorials here are a bit confusing on the command above - they seem to imply that you can run pacstrap new packages as you read on, and they don't mention systemd-dummy:
https://wiki.parabola.nu/Beginners%27_Guide
https://wiki.parabola.nu/Installation_Guide

i have set up grub as the guides mention and i added this to /etc/inittab (which was empty):
x:5:respawn:/usr/sbin/lxdm >& /dev/null

now i can boot the kernel but grub gets stuck after loading it (i know it was loaded because i added an echo "kernel loaded" after loading it in grub.cfg)

i gave up at this point as i have no idea what i am doing

as a desktop user with not much knowledge of all this stuff, i would really appreciate it if i could just use a GUI installer and follow a few steps to install a base desktop system that i can then extend by installing packages

History

#1

Updated by bill-auger about 15 hours ago

  • Assignee set to bill-auger
  • Status changed from unconfirmed to confirmed
  • Category set to Installer

just realized i never commented on this - its not ignored though - ive set myself to the task this week of getting out the next batch of ISOs and installers

Also available in: Atom PDF