Project

General

Profile

Bug #2784

qutebrowser has unresolvable dependencies

jgart - 5 days ago - . Updated 4 days ago.

Status:
in progress
Priority:
bug
Assignee:
-
% Done:

0%


Description

I get the following issue when trying to install qutebrowser:

$ sudo pacman -S qutebrowser

resolving dependencies...
warning: cannot resolve "python<3.8.3", a dependency of "qutebrowser"
:: The following package cannot be upgraded due to unresolvable dependencies:
qutebrowser

:: Do you want to skip the above package for this upgrade? [y/N]

History

#1

Updated by bill-auger 5 days ago

i can not reproduce this - the current 'python' version is 3.8.2
- 'qutebrowser' installs and runs as expected

$ pacman -Ss ^python$
extra/python 3.8.2-2 [instalita]
#2

Updated by jgart 5 days ago

My current python version is:

~ $ python --version
Python 3.8.3

Should I try downgrading python?

Except there's no python in my:

~ $ sudo pacman U /var/cache/pacman/pkg/python

#3

Updated by bill-auger 5 days ago

ok based on the IRC discussion, i have a clue what the problem is - you apparently migrated from arch to parabola only since yesterday; and you have the arch python package installed - that was upgraded yesterday - that upgraded package may not propagate to all parabola mirrors until tomorrow

if you need to use qutebrowser today, you could downgrade python or rebuild qutebrowser

in any case, python-3.8.3 is in some of the repos now; so qutebrowser needs to be rebuilt

#4

Updated by bill-auger 5 days ago

'qutebrowser' v1.11.1 fixes this

ARM still needs rebuilding

python 3.8.3 is in i686/testing

#5

Updated by bill-auger 5 days ago

  • Status changed from unconfirmed to in progress
#6

Updated by jgart 4 days ago

Just mentioning here that the update fixed it for me. I have qutebrowser working now. Thank you!

Also available in: Atom PDF